aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorClaudiu Beznea <claudiu.beznea@microchip.com>2022-06-29 14:17:17 +0300
committerHauke Mehrtens <hauke@hauke-m.de>2022-07-31 17:12:47 +0200
commit972b833e9161697beacb4286c8c91aeeec1161fe (patch)
tree656fdac999d3fcd09a59d244dda8e58f07dd1a53
parent39810995fb9cbb667bcec93612b369388a02c4da (diff)
downloadupstream-972b833e9161697beacb4286c8c91aeeec1161fe.tar.gz
upstream-972b833e9161697beacb4286c8c91aeeec1161fe.tar.bz2
upstream-972b833e9161697beacb4286c8c91aeeec1161fe.zip
uboot-at91: update to linux4sam-2022.04
Update uboot-at91 to linux4sam-2022.04. As linux4sam-2022.04 is based on U-Boot v2022.01 which contains commit 93b196532254 ("Makefile: Only build dtc if needed") removed also the DTC variable passed to MAKE to force the compilation of DTC. Signed-off-by: Claudiu Beznea <claudiu.beznea@microchip.com> (cherry picked from commit 6d5611af2813e5f06fbf9b400ef0fe642f16c566)
-rw-r--r--package/boot/uboot-at91/Makefile7
-rw-r--r--package/boot/uboot-at91/patches/001-fix-Wformat-security.patch15
2 files changed, 6 insertions, 16 deletions
diff --git a/package/boot/uboot-at91/Makefile b/package/boot/uboot-at91/Makefile
index ed69b8b06c..394cd7a42a 100644
--- a/package/boot/uboot-at91/Makefile
+++ b/package/boot/uboot-at91/Makefile
@@ -7,13 +7,13 @@
include $(TOPDIR)/rules.mk
-PKG_VERSION:=linux4sam-2021.10
+PKG_VERSION:=linux4sam-2022.04
PKG_RELEASE:=$(AUTORELEASE)
PKG_SOURCE_PROTO:=git
PKG_SOURCE_URL:=https://github.com/linux4sam/u-boot-at91.git
-PKG_MIRROR_HASH:=f1190062f2012b182b45b78263a4cce4ada9b7b8d6f5a66d68fa51437105fc8c
-PKG_SOURCE_VERSION:=39854ce82232cdc05c20158d0439bdbc40991e4a
+PKG_MIRROR_HASH:=56bbac45f71aaf39b365661db2a76c6c8415e27f7147b27bb58312b12756c8f3
+PKG_SOURCE_VERSION:=7b59654a486d39dc8e0343e2554699b8a79c7a54
include $(INCLUDE_DIR)/u-boot.mk
include $(INCLUDE_DIR)/package.mk
@@ -174,7 +174,6 @@ UBOOT_TARGETS := \
define Build/Compile
+$(MAKE) $(PKG_JOBS) -C $(PKG_BUILD_DIR) \
CROSS_COMPILE=$(TARGET_CROSS) \
- DTC=$(PKG_BUILD_DIR)/scripts/dtc/dtc \
KCFLAGS="$(filter-out -fstack-protector \
-mfloat-abi=hard, $(TARGET_CFLAGS)) -mfloat-abi=soft"
endef
diff --git a/package/boot/uboot-at91/patches/001-fix-Wformat-security.patch b/package/boot/uboot-at91/patches/001-fix-Wformat-security.patch
index d39a91aaf0..de92dd4167 100644
--- a/package/boot/uboot-at91/patches/001-fix-Wformat-security.patch
+++ b/package/boot/uboot-at91/patches/001-fix-Wformat-security.patch
@@ -10,11 +10,9 @@ Signed-off-by: Claudiu Beznea <claudiu.beznea@microchip.com>
drivers/pinctrl/pinctrl-uclass.c | 2 +-
3 files changed, 3 insertions(+), 3 deletions(-)
-diff --git a/cmd/panic.c b/cmd/panic.c
-index f13b3f094fab..197e2d0870ff 100644
--- a/cmd/panic.c
+++ b/cmd/panic.c
-@@ -11,7 +11,7 @@ static int do_panic(struct cmd_tbl *cmdtp, int flag, int argc,
+@@ -11,7 +11,7 @@ static int do_panic(struct cmd_tbl *cmdt
{
char *text = (argc < 2) ? "" : argv[1];
@@ -23,11 +21,9 @@ index f13b3f094fab..197e2d0870ff 100644
return CMD_RET_SUCCESS;
}
-diff --git a/cmd/version.c b/cmd/version.c
-index 3686b8733249..35b52c48171d 100644
--- a/cmd/version.c
+++ b/cmd/version.c
-@@ -19,7 +19,7 @@ static int do_version(struct cmd_tbl *cmdtp, int flag, int argc,
+@@ -24,7 +24,7 @@ static int do_version(struct cmd_tbl *cm
{
char buf[DISPLAY_OPTIONS_BANNER_LENGTH];
@@ -36,11 +32,9 @@ index 3686b8733249..35b52c48171d 100644
#ifdef CC_VERSION_STRING
puts(CC_VERSION_STRING "\n");
#endif
-diff --git a/drivers/pinctrl/pinctrl-uclass.c b/drivers/pinctrl/pinctrl-uclass.c
-index b0f30aa1f758..aa62a890609a 100644
--- a/drivers/pinctrl/pinctrl-uclass.c
+++ b/drivers/pinctrl/pinctrl-uclass.c
-@@ -371,7 +371,7 @@ int pinctrl_get_pin_name(struct udevice *dev, int selector, char *buf,
+@@ -375,7 +375,7 @@ int pinctrl_get_pin_name(struct udevice
if (!ops->get_pin_name)
return -ENOSYS;
@@ -49,6 +43,3 @@ index b0f30aa1f758..aa62a890609a 100644
return 0;
}
---
-2.33.0
-