diff options
author | Felix Fietkau <nbd@openwrt.org> | 2007-07-30 14:50:15 +0000 |
---|---|---|
committer | Felix Fietkau <nbd@openwrt.org> | 2007-07-30 14:50:15 +0000 |
commit | e23c6c4b6b4e7e01ee3ecf07729dc8860a5a40d3 (patch) | |
tree | ea0b13f2897712070315cb2f2705c648865a0d1f | |
parent | c517fb2ad4e68b50832bf7491e27edb33b4672cc (diff) | |
download | upstream-e23c6c4b6b4e7e01ee3ecf07729dc8860a5a40d3.tar.gz upstream-e23c6c4b6b4e7e01ee3ecf07729dc8860a5a40d3.tar.bz2 upstream-e23c6c4b6b4e7e01ee3ecf07729dc8860a5a40d3.zip |
fix verbose output with dash as /bin/sh
SVN-Revision: 8227
-rw-r--r-- | Makefile | 2 | ||||
-rw-r--r-- | include/host.mk | 1 | ||||
-rw-r--r-- | include/verbose.mk | 2 |
3 files changed, 4 insertions, 1 deletions
@@ -18,6 +18,8 @@ ifneq ($(OPENWRT_BUILD),1) export OPENWRT_BUILD:=1 include $(TOPDIR)/include/toplevel.mk else + include $(TOPDIR)/include/host.mk + include rules.mk include $(INCLUDE_DIR)/depends.mk include $(INCLUDE_DIR)/subdir.mk diff --git a/include/host.mk b/include/host.mk index cc0436e7b0..8b2e56ce51 100644 --- a/include/host.mk +++ b/include/host.mk @@ -8,6 +8,7 @@ -include $(TMP_DIR)/.host.mk export TAR +TMP_DIR ?= $(TOPDIR)/tmp ifneq ($(__host_inc),1) __host_inc:=1 diff --git a/include/verbose.mk b/include/verbose.mk index f18e9a2c71..5ceaf9999c 100644 --- a/include/verbose.mk +++ b/include/verbose.mk @@ -26,7 +26,7 @@ ifeq ($(IS_TTY),1) endif define MESSAGE - echo -e "$(_Y)$(1)$(_N)" >&3 + /bin/echo -e "$(_Y)$(1)$(_N)" >&3 endef ifneq ($(KBUILD_VERBOSE),99) |