aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJohn Audia <graysky@archlinux.us>2021-10-09 13:44:30 -0400
committerDaniel Golle <daniel@makrotopia.org>2021-10-10 00:12:55 +0100
commitb5893a4128ad0c8551c051f563b8e451c3331820 (patch)
tree036b828dde95997d39e6adb58667849fa94103b9
parent416eef7209f3d7c7ab27c90dc4d851d78fff2d44 (diff)
downloadupstream-b5893a4128ad0c8551c051f563b8e451c3331820.tar.gz
upstream-b5893a4128ad0c8551c051f563b8e451c3331820.tar.bz2
upstream-b5893a4128ad0c8551c051f563b8e451c3331820.zip
kernel: bump 5.4 to 5.4.152
All patches automatically rebased. Signed-off-by: John Audia <graysky@archlinux.us>
-rw-r--r--include/kernel-version.mk4
-rw-r--r--target/linux/generic/pending-5.4/834-ledtrig-libata.patch10
2 files changed, 7 insertions, 7 deletions
diff --git a/include/kernel-version.mk b/include/kernel-version.mk
index 5c9b5256ae..734dbeda92 100644
--- a/include/kernel-version.mk
+++ b/include/kernel-version.mk
@@ -6,10 +6,10 @@ ifdef CONFIG_TESTING_KERNEL
KERNEL_PATCHVER:=$(KERNEL_TESTING_PATCHVER)
endif
-LINUX_VERSION-5.4 = .151
+LINUX_VERSION-5.4 = .152
LINUX_VERSION-5.10 = .72
-LINUX_KERNEL_HASH-5.4.151 = bbe73fb83c31a6a7269de85b6b2bbd54dd31e6613f4edab20bb7a6f37cf53313
+LINUX_KERNEL_HASH-5.4.152 = 8044c7134c5eed21af9662f1c5399a5d8781b5bc2d8979e9ad06b4435a0a5ed5
LINUX_KERNEL_HASH-5.10.72 = b4d635afe7646ac6a6617c738e747ba0a6006675cd9735d18f672f8b1fba4c7c
remove_uri_prefix=$(subst git://,,$(subst http://,,$(subst https://,,$(1))))
diff --git a/target/linux/generic/pending-5.4/834-ledtrig-libata.patch b/target/linux/generic/pending-5.4/834-ledtrig-libata.patch
index cb049af0a5..f33ceec126 100644
--- a/target/linux/generic/pending-5.4/834-ledtrig-libata.patch
+++ b/target/linux/generic/pending-5.4/834-ledtrig-libata.patch
@@ -65,7 +65,7 @@ Signed-off-by: Daniel Golle <daniel@makrotopia.org>
/**
* ata_build_rw_tf - Build ATA taskfile for given read/write request
* @tf: Target ATA taskfile
-@@ -5121,6 +5134,9 @@ struct ata_queued_cmd *ata_qc_new_init(s
+@@ -5149,6 +5162,9 @@ struct ata_queued_cmd *ata_qc_new_init(s
if (tag < 0)
return NULL;
}
@@ -75,7 +75,7 @@ Signed-off-by: Daniel Golle <daniel@makrotopia.org>
qc = __ata_qc_from_tag(ap, tag);
qc->tag = qc->hw_tag = tag;
-@@ -6057,6 +6073,9 @@ struct ata_port *ata_port_alloc(struct a
+@@ -6085,6 +6101,9 @@ struct ata_port *ata_port_alloc(struct a
ap->stats.unhandled_irq = 1;
ap->stats.idle_irq = 1;
#endif
@@ -85,7 +85,7 @@ Signed-off-by: Daniel Golle <daniel@makrotopia.org>
ata_sff_port_init(ap);
return ap;
-@@ -6092,6 +6111,12 @@ static void ata_host_release(struct kref
+@@ -6120,6 +6139,12 @@ static void ata_host_release(struct kref
kfree(ap->pmp_link);
kfree(ap->slave_link);
@@ -98,7 +98,7 @@ Signed-off-by: Daniel Golle <daniel@makrotopia.org>
kfree(ap);
host->ports[i] = NULL;
}
-@@ -6555,7 +6580,23 @@ int ata_host_register(struct ata_host *h
+@@ -6583,7 +6608,23 @@ int ata_host_register(struct ata_host *h
host->ports[i]->print_id = atomic_inc_return(&ata_print_id);
host->ports[i]->local_port_no = i + 1;
}
@@ -134,7 +134,7 @@ Signed-off-by: Daniel Golle <daniel@makrotopia.org>
/*
* Define if arch has non-standard setup. This is a _PCI_ standard
-@@ -881,6 +884,12 @@ struct ata_port {
+@@ -882,6 +885,12 @@ struct ata_port {
#ifdef CONFIG_ATA_ACPI
struct ata_acpi_gtm __acpi_init_gtm; /* use ata_acpi_init_gtm() */
#endif