aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Kennedy <hurricos@gmail.com>2022-04-26 17:04:06 -0400
committerHauke Mehrtens <hauke@hauke-m.de>2022-05-01 13:23:12 +0200
commita142d96ade462e2b9bb922c8e615d3811066e794 (patch)
treee216a2eff0c75daf36f8bcd550616cb1b87df56c
parentfbd9605a908dc514ebf669589d40ea38c1d25134 (diff)
downloadupstream-a142d96ade462e2b9bb922c8e615d3811066e794.tar.gz
upstream-a142d96ade462e2b9bb922c8e615d3811066e794.tar.bz2
upstream-a142d96ade462e2b9bb922c8e615d3811066e794.zip
mpc85xx: Fix output location of padded dtb
In commit 7e614820a892 ("mpc85xx: add support for Extreme Networks WS-AP3825i"), we borrowed a recipe convention from apm821xx for device tree blob padding. Unfortunately, in the apm821xx target, the image recipes name the device tree blob differently, meaning that in mpc85xx, the padded dtb is never consumed. Change the definition of `Build/dtb` so that it outputs the padded dtb to the correct location for it to be consumed. Also, rename the recipe to `Build/pad-dtb`, so it is clear we are building and padding the device tree blob. This change fixes Github issue #9779 [1]. [1]: https://github.com/openwrt/openwrt/issues/9779 Fixes: 7e614820a892 ("mpc85xx: add support for Extreme Networks WS-AP3825i") Signed-off-by: Martin Kennedy <hurricos@gmail.com> (cherry picked from commit 1d06277407d3e294589ecde46328303a9f3803fd)
-rw-r--r--target/linux/mpc85xx/image/Makefile4
-rw-r--r--target/linux/mpc85xx/image/p1020.mk2
2 files changed, 3 insertions, 3 deletions
diff --git a/target/linux/mpc85xx/image/Makefile b/target/linux/mpc85xx/image/Makefile
index e1d1bc6948..d502650a32 100644
--- a/target/linux/mpc85xx/image/Makefile
+++ b/target/linux/mpc85xx/image/Makefile
@@ -5,8 +5,8 @@ include $(INCLUDE_DIR)/image.mk
DEVICE_VARS += DTB_SIZE
-define Build/dtb
- $(call Image/BuildDTB,$(DTS_DIR)/$(DEVICE_DTS).dts,$@.dtb,,--space $(DTB_SIZE))
+define Build/pad-dtb
+ $(call Image/BuildDTB,$(DTS_DIR)/$(DEVICE_DTS).dts,$(dir $@)/image-$(DEVICE_DTS).dtb,,--space $(DTB_SIZE))
endef
define Device/Default
diff --git a/target/linux/mpc85xx/image/p1020.mk b/target/linux/mpc85xx/image/p1020.mk
index 234bdc26a1..6fdbfd664a 100644
--- a/target/linux/mpc85xx/image/p1020.mk
+++ b/target/linux/mpc85xx/image/p1020.mk
@@ -74,7 +74,7 @@ define Device/extreme-networks_ws-ap3825i
DEVICE_PACKAGES := kmod-ath10k-ct ath10k-firmware-qca988x-ct
BLOCKSIZE := 128k
DTB_SIZE := 20480
- KERNEL = kernel-bin | lzma | dtb | fit lzma $(KDIR)/image-$$(DEVICE_DTS).dtb
+ KERNEL = kernel-bin | lzma | pad-dtb | fit lzma $(KDIR)/image-$$(DEVICE_DTS).dtb
IMAGES := sysupgrade.bin
IMAGE/sysupgrade.bin := append-kernel | append-rootfs | pad-rootfs | append-metadata
endef