diff options
author | Syrone Wong <wong.syrone@gmail.com> | 2018-06-21 23:08:11 +0800 |
---|---|---|
committer | Felix Fietkau <nbd@nbd.name> | 2018-07-22 17:16:52 +0200 |
commit | da9d760ea1c0450e9e6b1c0cdd5331e633c75887 (patch) | |
tree | 2e339988b4c52413f078663d0664f82d7b325d7c | |
parent | 139f99c05880508b19308eed366d8fbf5804fbf9 (diff) | |
download | upstream-da9d760ea1c0450e9e6b1c0cdd5331e633c75887.tar.gz upstream-da9d760ea1c0450e9e6b1c0cdd5331e633c75887.tar.bz2 upstream-da9d760ea1c0450e9e6b1c0cdd5331e633c75887.zip |
rules.mk: replace iremap when using GCC 8
The original -iremap is replaced by -fmacro-prefix-map in GCC 8
Signed-off-by: Syrone Wong <wong.syrone@gmail.com>
-rw-r--r-- | rules.mk | 4 |
1 files changed, 4 insertions, 0 deletions
@@ -141,6 +141,10 @@ endif ifeq ($(or $(CONFIG_EXTERNAL_TOOLCHAIN),$(CONFIG_GCC_VERSION_4_8),$(CONFIG_TARGET_uml)),) iremap = -iremap$(1):$(2) + # just overwrite iremap for GCC 8.1 and higher to keep backward compatibility + ifeq ($(CONFIG_GCC_VERSION_8),y) + iremap = -fmacro-prefix-map=$(1)=$(2) + endif endif PACKAGE_DIR:=$(BIN_DIR)/packages |