aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2019-11-02 19:54:04 -0700
committerHauke Mehrtens <hauke@hauke-m.de>2019-11-09 14:33:42 +0100
commitcabaaf06fe4185aa51c46aa8cd3b4041904f624a (patch)
tree17f95021e41663dc28e703af571b5745839121d6
parent7f4cef67c20517e4d5ed11d6e9cd6db0cd0e375b (diff)
downloadupstream-cabaaf06fe4185aa51c46aa8cd3b4041904f624a.tar.gz
upstream-cabaaf06fe4185aa51c46aa8cd3b4041904f624a.tar.bz2
upstream-cabaaf06fe4185aa51c46aa8cd3b4041904f624a.zip
nghttp2: Fix pkgconfig file
lib and includedir point to the host, not staging_dir. Note that prefix and exec_prefix is overriden to point to staging_dir. As CMAKE_INSTTALL is passed, switched InstallDev to use cmake.mk's rule. Signed-off-by: Rosen Penev <rosenp@gmail.com>
-rw-r--r--package/libs/nghttp2/Makefile12
1 files changed, 5 insertions, 7 deletions
diff --git a/package/libs/nghttp2/Makefile b/package/libs/nghttp2/Makefile
index 4fb26319ad..1d364c7023 100644
--- a/package/libs/nghttp2/Makefile
+++ b/package/libs/nghttp2/Makefile
@@ -2,9 +2,9 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=nghttp2
PKG_VERSION:=1.39.2
-PKG_RELEASE:=1
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
+PKG_RELEASE:=2
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
PKG_SOURCE_URL:=https://github.com/nghttp2/nghttp2/releases/download/v$(PKG_VERSION)
PKG_HASH:=a2d216450abd2beaf4e200c168957968e89d602ca4119338b9d7ab059fd4ce8b
@@ -31,11 +31,9 @@ CMAKE_OPTIONS += \
-DENABLE_LIB_ONLY=ON
define Build/InstallDev
- $(INSTALL_DIR) $(1)/usr/include/nghttp2
- $(INSTALL_DATA) $(PKG_INSTALL_DIR)/usr/include/nghttp2/*.h $(1)/usr/include/nghttp2/
- $(INSTALL_DIR) $(1)/usr/lib/pkgconfig
- $(INSTALL_DATA) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/*.pc $(1)/usr/lib/pkgconfig/
- $(CP) $(PKG_INSTALL_DIR)/usr/lib/libnghttp2.so* $(1)/usr/lib/
+ $(call Build/InstallDev/cmake,$(1))
+ $(SED) 's,/usr/include,$$$${prefix}/include,g' $(1)/usr/lib/pkgconfig/libnghttp2.pc
+ $(SED) 's,/usr/lib,$$$${prefix}/lib,g' $(1)/usr/lib/pkgconfig/libnghttp2.pc
endef
define Package/libnghttp2/install