aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNick Hainke <vincent@systemli.org>2022-04-05 15:26:24 +0200
committerDaniel Golle <daniel@makrotopia.org>2022-04-10 16:26:01 +0100
commit8215bba00e7d280a6bec75a063beb795339e3c6e (patch)
treeaa71df26822a615eab3d0f8ecad250876ed073ba
parent8f4124c2521c30a79270163c8d6c4ccda336fb8e (diff)
downloadupstream-8215bba00e7d280a6bec75a063beb795339e3c6e.tar.gz
upstream-8215bba00e7d280a6bec75a063beb795339e3c6e.tar.bz2
upstream-8215bba00e7d280a6bec75a063beb795339e3c6e.zip
libnfnetlink: update to 1.0.2
Changes: c63f193 bump version to 1.0.2 3cffa84 libnfnetlink: Check getsockname() return code 90ba679 include: Silence gcc warning in linux_list.h bb4f6c8 Make it clear that this library is deprecated e46569c Minimally resurrect doxygen documentation 5087de4 libnfnetlink: hide private symbols 62ca426 autogen: don't convert __u16 to u_int16_t efa1d8e src: Use stdint types everywhere 7a1a07c include: Sync with kernel headers 7633f0c libnfnetlink: initialize attribute padding to resolve valgrind warnings 94b68f3 configure: uclinux is also linux 617fe82 src: get source code license header in sync with current licensing terms 97a3960 build: resolve automake-1.12 warnings Removed the patch 100-missing_include.patch, libnfnetlink compiles fine with musl without this patch. Signed-off-by: Nick Hainke <vincent@systemli.org> (cherry picked from commit aecf088b3792d556c717510304729fa542ceb770)
-rw-r--r--package/libs/libnfnetlink/Makefile6
-rw-r--r--package/libs/libnfnetlink/patches/100-missing_include.patch20
2 files changed, 3 insertions, 23 deletions
diff --git a/package/libs/libnfnetlink/Makefile b/package/libs/libnfnetlink/Makefile
index bc64ff111d..57bb0cdb98 100644
--- a/package/libs/libnfnetlink/Makefile
+++ b/package/libs/libnfnetlink/Makefile
@@ -8,14 +8,14 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=libnfnetlink
-PKG_VERSION:=1.0.1
-PKG_RELEASE:=4
+PKG_VERSION:=1.0.2
+PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
PKG_SOURCE_URL:= \
http://www.netfilter.org/projects/libnfnetlink/files/ \
ftp://ftp.netfilter.org/pub/libnfnetlink/
-PKG_HASH:=f270e19de9127642d2a11589ef2ec97ef90a649a74f56cf9a96306b04817b51a
+PKG_HASH:=b064c7c3d426efb4786e60a8e6859b82ee2f2c5e49ffeea640cfe4fe33cbc376
PKG_MAINTAINER:=Jo-Philipp Wich <jo@mein.io>
PKG_LICENSE:=GPL-2.0+
diff --git a/package/libs/libnfnetlink/patches/100-missing_include.patch b/package/libs/libnfnetlink/patches/100-missing_include.patch
deleted file mode 100644
index 163307d895..0000000000
--- a/package/libs/libnfnetlink/patches/100-missing_include.patch
+++ /dev/null
@@ -1,20 +0,0 @@
---- a/include/libnfnetlink/libnfnetlink.h
-+++ b/include/libnfnetlink/libnfnetlink.h
-@@ -15,6 +15,7 @@
- #define aligned_u64 unsigned long long __attribute__((aligned(8)))
- #endif
-
-+#include <sys/types.h>
- #include <sys/socket.h> /* for sa_family_t */
- #include <linux/netlink.h>
- #include <libnfnetlink/linux_nfnetlink.h>
---- a/include/libnfnetlink/linux_nfnetlink.h
-+++ b/include/libnfnetlink/linux_nfnetlink.h
-@@ -1,6 +1,6 @@
- #ifndef _NFNETLINK_H
- #define _NFNETLINK_H
--#include <linux/types.h>
-+#include <sys/types.h>
- #include <libnfnetlink/linux_nfnetlink_compat.h>
-
- enum nfnetlink_groups {