aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2021-10-09 12:24:44 -0700
committerDaniel Golle <daniel@makrotopia.org>2021-10-10 19:39:32 +0100
commit7c0fb874436c0613a042c8b07aa00621d08f4eaa (patch)
treeac524f890923a4a6cb52328d12385108c1edd3b0
parent81d694e30b4926fea057bd3e46d996a8f098b95a (diff)
downloadupstream-7c0fb874436c0613a042c8b07aa00621d08f4eaa.tar.gz
upstream-7c0fb874436c0613a042c8b07aa00621d08f4eaa.tar.bz2
upstream-7c0fb874436c0613a042c8b07aa00621d08f4eaa.zip
tools/meson: fix usage with SDK
The python path cannot be embedded in the meson binary as it changes with the SDK. Signed-off-by: Rosen Penev <rosenp@gmail.com>
-rw-r--r--include/meson.mk2
-rw-r--r--tools/meson/Makefile2
2 files changed, 2 insertions, 2 deletions
diff --git a/include/meson.mk b/include/meson.mk
index 9862f0e662..12e38b9e71 100644
--- a/include/meson.mk
+++ b/include/meson.mk
@@ -56,7 +56,7 @@ MESON_CPU:="$(CPU_TYPE)$(if $(CPU_SUBTYPE),+$(CPU_SUBTYPE))"
endif
define Meson
- $(2) $(STAGING_DIR_HOST)/bin/meson $(1)
+ $(2) $(STAGING_DIR_HOST)/bin/$(PYTHON) $(STAGING_DIR_HOST)/bin/meson $(1)
endef
define Meson/CreateNativeFile
diff --git a/tools/meson/Makefile b/tools/meson/Makefile
index 0cf0efba47..1aab5d8fcb 100644
--- a/tools/meson/Makefile
+++ b/tools/meson/Makefile
@@ -21,7 +21,7 @@ endef
define Host/Install
$(INSTALL_DIR) $(STAGING_DIR_HOST)/bin
- $(HOST_BUILD_DIR)/packaging/create_zipapp.py $(HOST_BUILD_DIR) --interpreter $(STAGING_DIR_HOST)/bin/$(PYTHON) --outfile $(STAGING_DIR_HOST)/bin/meson
+ $(HOST_BUILD_DIR)/packaging/create_zipapp.py $(HOST_BUILD_DIR) --outfile $(STAGING_DIR_HOST)/bin/meson
$(INSTALL_DIR) $(STAGING_DIR_HOST)/lib/meson
$(INSTALL_CONF) files/openwrt-cross.txt.in $(STAGING_DIR_HOST)/lib/meson/
$(INSTALL_CONF) files/openwrt-native.txt.in $(STAGING_DIR_HOST)/lib/meson/