aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2021-09-23 23:44:57 -0700
committerHauke Mehrtens <hauke@hauke-m.de>2022-04-05 00:20:24 +0200
commit308adb76d2ad7a820575ca41aa96970e8e337220 (patch)
treec872fc25c1c32680cce9912c01a3852bade75721
parent55740b1ba47bc3719d9d8d5e881490ea1db7086e (diff)
downloadupstream-308adb76d2ad7a820575ca41aa96970e8e337220.tar.gz
upstream-308adb76d2ad7a820575ca41aa96970e8e337220.tar.bz2
upstream-308adb76d2ad7a820575ca41aa96970e8e337220.zip
musl-fts: remove shared libraries from host
Avoids having to add rpath to the various packages using it. Also add PIC to fix compilation as static libraries do not use PIC by default. Fixes: 1fb099341e58 ("musl-fts: add host build") Signed-off-by: Rosen Penev <rosenp@gmail.com> (cherry picked from commit 8a75ed4ba07b9d64ae547ce36873e51ba54f0eaf)
-rw-r--r--package/libs/musl-fts/Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/package/libs/musl-fts/Makefile b/package/libs/musl-fts/Makefile
index 494f700f8a..9f4bdf12a3 100644
--- a/package/libs/musl-fts/Makefile
+++ b/package/libs/musl-fts/Makefile
@@ -43,6 +43,7 @@ define Package/musl-fts/description
The musl-fts package implements the fts(3) functions fts_open, fts_read, fts_children, fts_set and fts_close, which are missing in musl libc.
endef
+HOST_CONFIGURE_ARGS += --disable-shared --with-pic
define Build/InstallDev
$(INSTALL_DIR) $(1)/usr/include