aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorOscar Molnar <oscar@tymscar.com>2022-08-06 16:13:41 +0100
committerHauke Mehrtens <hauke@hauke-m.de>2022-08-14 21:06:53 +0200
commitda7e9b201e6199030d9838ba82b3bd0399ba6d23 (patch)
tree46b925d0483c3b4c1a0c0bd25f50bd7963510f14
parentdfe5c2359246c8643f85de286a427695abeaacfd (diff)
downloadupstream-da7e9b201e6199030d9838ba82b3bd0399ba6d23.tar.gz
upstream-da7e9b201e6199030d9838ba82b3bd0399ba6d23.tar.bz2
upstream-da7e9b201e6199030d9838ba82b3bd0399ba6d23.zip
build: add support for python3.11 and higher
python3.11 beta is out but fails to run the makefile currently this supports python versions from 3.6 to 3.99 with the python3 binary it also checks specifically for 3.11 as it is the latest version out Signed-off-by: Oscar Molnar <oscar@tymscar.com> (cherry picked from commit a9e8eec221874e5840d659aed3f68850ff1d9982)
-rw-r--r--include/prereq-build.mk6
1 files changed, 4 insertions, 2 deletions
diff --git a/include/prereq-build.mk b/include/prereq-build.mk
index 80d549af39..70e1061680 100644
--- a/include/prereq-build.mk
+++ b/include/prereq-build.mk
@@ -162,20 +162,22 @@ $(eval $(call SetupHostCommand,perl,Please install Perl 5.x, \
$(eval $(call CleanupPython2))
$(eval $(call SetupHostCommand,python,Please install Python >= 3.6, \
+ python3.11 -V 2>&1 | grep 'Python 3', \
python3.10 -V 2>&1 | grep 'Python 3', \
python3.9 -V 2>&1 | grep 'Python 3', \
python3.8 -V 2>&1 | grep 'Python 3', \
python3.7 -V 2>&1 | grep 'Python 3', \
python3.6 -V 2>&1 | grep 'Python 3', \
- python3 -V 2>&1 | grep -E 'Python 3\.([6-9]|10)\.?'))
+ python3 -V 2>&1 | grep -E 'Python 3\.([6-9]|[0-9][0-9])\.?'))
$(eval $(call SetupHostCommand,python3,Please install Python >= 3.6, \
+ python3.11 -V 2>&1 | grep 'Python 3', \
python3.10 -V 2>&1 | grep 'Python 3', \
python3.9 -V 2>&1 | grep 'Python 3', \
python3.8 -V 2>&1 | grep 'Python 3', \
python3.7 -V 2>&1 | grep 'Python 3', \
python3.6 -V 2>&1 | grep 'Python 3', \
- python3 -V 2>&1 | grep -E 'Python 3\.([6-9]|10)\.?'))
+ python3 -V 2>&1 | grep -E 'Python 3\.([6-9]|[0-9][0-9])\.?'))
$(eval $(call TestHostCommand,python3-distutils, \
Please install the Python3 distutils module, \