aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorEtienne Champetier <champetier.etienne@gmail.com>2022-08-20 18:08:15 -0400
committerHauke Mehrtens <hauke@hauke-m.de>2022-08-28 00:41:40 +0200
commita901a13505e13f2d0e60ceaa85d19feea15d4cd4 (patch)
treef18c8f9697da6be0a8cbd0c93a1b98498e1ceffe
parentd1f14d17aaa1866eee1fe2d0d074b2a003c2a210 (diff)
downloadupstream-a901a13505e13f2d0e60ceaa85d19feea15d4cd4.tar.gz
upstream-a901a13505e13f2d0e60ceaa85d19feea15d4cd4.tar.bz2
upstream-a901a13505e13f2d0e60ceaa85d19feea15d4cd4.zip
iptables: default to ip(6)tables-nft when using buildroot
35fec487e30f05c81bd135326a993dad7f861812 fixed opkg usage, but when using buildroot we were still defaulting to ip(6)tables-legacy Signed-off-by: Etienne Champetier <champetier.etienne@gmail.com> (cherry picked from commit 0c8d7e34ab35f6b41f034fd94fec740970e0125b)
-rw-r--r--package/network/utils/iptables/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/package/network/utils/iptables/Makefile b/package/network/utils/iptables/Makefile
index 6cf3ca8e91..5fc2db07fb 100644
--- a/package/network/utils/iptables/Makefile
+++ b/package/network/utils/iptables/Makefile
@@ -751,11 +751,11 @@ $(eval $(call BuildPackage,libiptext))
$(eval $(call BuildPackage,libiptext6))
$(eval $(call BuildPackage,libiptext-nft))
$(eval $(call BuildPackage,xtables-legacy))
-$(eval $(call BuildPackage,iptables-zz-legacy))
$(eval $(call BuildPackage,xtables-nft))
$(eval $(call BuildPackage,arptables-nft))
$(eval $(call BuildPackage,ebtables-nft))
$(eval $(call BuildPackage,iptables-nft))
+$(eval $(call BuildPackage,iptables-zz-legacy))
$(eval $(call BuildPlugin,iptables-mod-conntrack-extra,$(IPT_CONNTRACK_EXTRA-m)))
$(eval $(call BuildPlugin,iptables-mod-conntrack-label,$(IPT_CONNTRACK_LABEL-m)))
$(eval $(call BuildPlugin,iptables-mod-extra,$(IPT_EXTRA-m)))
@@ -778,8 +778,8 @@ $(eval $(call BuildPlugin,iptables-mod-nflog,$(IPT_NFLOG-m)))
$(eval $(call BuildPlugin,iptables-mod-trace,$(IPT_DEBUG-m)))
$(eval $(call BuildPlugin,iptables-mod-nfqueue,$(IPT_NFQUEUE-m)))
$(eval $(call BuildPlugin,iptables-mod-checksum,$(IPT_CHECKSUM-m)))
-$(eval $(call BuildPackage,ip6tables-zz-legacy))
$(eval $(call BuildPackage,ip6tables-nft))
+$(eval $(call BuildPackage,ip6tables-zz-legacy))
$(eval $(call BuildPlugin,ip6tables-extra,$(IPT_IPV6_EXTRA-m)))
$(eval $(call BuildPlugin,ip6tables-mod-nat,$(IPT_NAT6-m)))