aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorClaudiu Beznea <claudiu.beznea@microchip.com>2021-10-11 11:47:26 +0300
committerHauke Mehrtens <hauke@hauke-m.de>2021-10-24 18:52:29 +0200
commit8746ba3657b2c328ad23a6adcbe5fb6a9e87c490 (patch)
tree7ca9c3f5627cfc51de1ea8ea66c9918a3c0f9313
parent65c4e89dcf01ca5e4ab3e5c2564fb8ca42757f8c (diff)
downloadupstream-8746ba3657b2c328ad23a6adcbe5fb6a9e87c490.tar.gz
upstream-8746ba3657b2c328ad23a6adcbe5fb6a9e87c490.tar.bz2
upstream-8746ba3657b2c328ad23a6adcbe5fb6a9e87c490.zip
at91: add support for sam9x60-ek board
Add support for SAM9X60-EK board. Hardware: - SoC: SAM9X60 - RAM: Winbond W972GG6KB-25 (2Gbit DDR2) - NAND Flash: Micron MT29F4G08ABAEA - QSPI Flash: Microchip SST26VF064B - EEPROM: Microchip 24AA02E48 - SDMMC: One standard 4-bit SD card interface - USB: two stacked Type-A connectors with power switches, one micro-B USB device - CAN: 2 interfaces (Microchip MCP2542) - Ethernet: one 10/100Mbps - WiFi/BT: one optional WiFi/Bluetooth interface - Audio: one ClassD port - Display: one 24-bit LCD interface - Camera: one 12-bit image sensor interface - IO: one IO expander (Microchip MCP23008) - Debug ports: one J-Link-OB + CDC, one JTAG interface - Leds: one RGB LED - Buttons: 4 push button switches - Expansion: one PIO connector, one mikrobus connector - Power management: two power regulators, two power consumption measurement devices Flashing: - follow the procedure at [1] [1] https://www.linux4sam.org/bin/view/Linux4SAM/Sam9x60EKMainPage#Create_a_SD_card_with_the_demo Signed-off-by: Claudiu Beznea <claudiu.beznea@microchip.com>
-rw-r--r--package/boot/at91bootstrap/Makefile14
-rw-r--r--package/boot/uboot-at91/Makefile14
-rw-r--r--target/linux/at91/image/sam9x.mk13
3 files changed, 39 insertions, 2 deletions
diff --git a/package/boot/at91bootstrap/Makefile b/package/boot/at91bootstrap/Makefile
index 8711acd286..2d77f70997 100644
--- a/package/boot/at91bootstrap/Makefile
+++ b/package/boot/at91bootstrap/Makefile
@@ -40,6 +40,18 @@ define AT91Bootstrap/at91sam9x5eksd_uboot
BUILD_DEVICES:=atmel_at91sam9x25ek atmel_at91sam9x35ek
endef
+define AT91Bootstrap/sam9x60eknf_uboot
+ NAME:=AT91Bootstrap for SAM9X60-EK board (NandFlash)
+ BUILD_SUBTARGET:=sam9x
+ BUILD_DEVICES:=microchip_sam9x60ek
+endef
+
+define AT91Bootstrap/sam9x60eksd_uboot
+ NAME:=AT91Bootstrap for SAM9X60-EK board (SDcard)
+ BUILD_SUBTARGET:=sam9x
+ BUILD_DEVICES:=microchip_sam9x60ek
+endef
+
define AT91Bootstrap/sama5d2_icpdf_qspi_uboot
TITLE:=AT91Bootstrap for SAMA5D2 ICP board (QSPI Flash)
BUILD_SUBTARGET:=sama5
@@ -145,6 +157,8 @@ endef
AT91BOOTSTRAP_TARGETS := \
at91sam9x5eknf_uboot \
at91sam9x5eksd_uboot \
+ sam9x60eknf_uboot \
+ sam9x60eksd_uboot \
sama5d2_icpdf_qspi_uboot \
sama5d2_icpsd_uboot \
sama5d2_xplaineddf_uboot \
diff --git a/package/boot/uboot-at91/Makefile b/package/boot/uboot-at91/Makefile
index 3262da4cbe..ad65247e3e 100644
--- a/package/boot/uboot-at91/Makefile
+++ b/package/boot/uboot-at91/Makefile
@@ -47,6 +47,18 @@ define U-Boot/at91sam9x5ek_mmc
atmel_at91sam9x35ek
endef
+define U-Boot/sam9x60ek_nandflash
+ NAME:=SAM9X60-EK board (NandFlash)
+ BUILD_SUBTARGET:=sam9x
+ BUILD_DEVICES:=microchip_sam9x60ek
+endef
+
+define U-Boot/sam9x60ek_mmc
+ NAME:=SAM9X60-EK board (SDcard)
+ BUILD_SUBTARGET:=sam9x
+ BUILD_DEVICES:=microchip_sam9x60ek
+endef
+
define U-Boot/sama5d3_xplained_nandflash
NAME:=SAMA5D3 Xplained board (NandFlash)
BUILD_SUBTARGET:=sama5
@@ -135,6 +147,8 @@ UBOOT_TARGETS := \
at91sam9m10g45ek_nandflash \
at91sam9x5ek_nandflash \
at91sam9x5ek_mmc \
+ sam9x60ek_nandflash \
+ sam9x60ek_mmc \
sama5d3_xplained_nandflash \
sama5d3_xplained_mmc \
sama5d2_icp_mmc \
diff --git a/target/linux/at91/image/sam9x.mk b/target/linux/at91/image/sam9x.mk
index 6f10123bba..b6c5e33ac4 100644
--- a/target/linux/at91/image/sam9x.mk
+++ b/target/linux/at91/image/sam9x.mk
@@ -16,11 +16,11 @@ define Build/at91-sdcard
::$(DEVICE_NAME)-fit.itb
mcopy -i $@.boot \
- $(BIN_DIR)/u-boot-at91sam9x5ek_mmc/u-boot.bin \
+ $(BIN_DIR)/u-boot-$(if $(findstring sam9x60,$@),$(DEVICE_DTS:at91-%=%),at91sam9x5ek)_mmc/u-boot.bin \
::u-boot.bin
mcopy -i $@.boot \
- $(BIN_DIR)/at91bootstrap-at91sam9x5eksd_uboot/at91bootstrap.bin \
+ $(BIN_DIR)/at91bootstrap-$(if $(findstring sam9x60,$@),$(DEVICE_DTS:at91-%=%),at91sam9x5ek)sd_uboot/at91bootstrap.bin \
::BOOT.bin
$(CP) uboot-env.txt $@-uboot-env.txt
@@ -112,6 +112,15 @@ define Device/atmel_at91sam9x35ek
endef
TARGET_DEVICES += atmel_at91sam9x35ek
+define Device/microchip_sam9x60ek
+ $(Device/evaluation-dtb)
+ DEVICE_VENDOR := Microchip
+ DEVICE_MODEL := SAM9X60-EK
+ DEVICE_DTS := at91-sam9x60ek
+ $(Device/evaluation-sdimage)
+endef
+TARGET_DEVICES += microchip_sam9x60ek
+
define Device/calamp_lmu5000
$(Device/production)
DEVICE_VENDOR := CalAmp