aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJosef Schlehofer <pepe.schlehofer@gmail.com>2022-06-07 13:13:11 +0200
committerPetr Štetiar <ynezz@true.cz>2022-08-16 15:24:14 +0200
commit659bb7638d7b5200c0d87b7ca642f8758199e568 (patch)
treee610bd0dc545b9fcdcb86c1b6523bb1e7ed050ea
parent89b7714cf65e432997ca3c738afbffbd73469956 (diff)
downloadupstream-659bb7638d7b5200c0d87b7ca642f8758199e568.tar.gz
upstream-659bb7638d7b5200c0d87b7ca642f8758199e568.tar.bz2
upstream-659bb7638d7b5200c0d87b7ca642f8758199e568.zip
mpc85xx: enable NAND support for all subtargets
In subtarget p2020, there wasn't enabled nand support, and because of that there weren't available tools from mtd-utils package, which has utilities for NAND flash memory even though reference board, which is the only currently supported device in p2020 subtarget has NAND [1]. All subtargets in mpc85xx has already enabled nand support, let's do it globally. [1] https://www.nxp.com/design/qoriq-developer-resources/p2020-reference-design-board:P2020RDB Signed-off-by: Josef Schlehofer <pepe.schlehofer@gmail.com> (cherry picked from commit 6006f73383cc7626552175010de23530bdcc8718)
-rw-r--r--target/linux/mpc85xx/Makefile2
-rw-r--r--target/linux/mpc85xx/p1010/target.mk1
-rw-r--r--target/linux/mpc85xx/p1020/target.mk1
3 files changed, 1 insertions, 3 deletions
diff --git a/target/linux/mpc85xx/Makefile b/target/linux/mpc85xx/Makefile
index 6bf096740e..398e578882 100644
--- a/target/linux/mpc85xx/Makefile
+++ b/target/linux/mpc85xx/Makefile
@@ -8,7 +8,7 @@ ARCH:=powerpc
BOARD:=mpc85xx
BOARDNAME:=Freescale MPC85xx
CPU_TYPE:=8540
-FEATURES:=squashfs ramdisk
+FEATURES:=squashfs ramdisk nand
SUBTARGETS:=p1010 p1020 p2020
KERNEL_PATCHVER:=5.10
diff --git a/target/linux/mpc85xx/p1010/target.mk b/target/linux/mpc85xx/p1010/target.mk
index 12ed78ace1..019536ff1a 100644
--- a/target/linux/mpc85xx/p1010/target.mk
+++ b/target/linux/mpc85xx/p1010/target.mk
@@ -1,5 +1,4 @@
BOARDNAME:=P1010
-FEATURES+=nand
KERNELNAME:=simpleImage.tl-wdr4900-v1
define Target/Description
diff --git a/target/linux/mpc85xx/p1020/target.mk b/target/linux/mpc85xx/p1020/target.mk
index a25409eebb..000fc64644 100644
--- a/target/linux/mpc85xx/p1020/target.mk
+++ b/target/linux/mpc85xx/p1020/target.mk
@@ -1,5 +1,4 @@
BOARDNAME:=P1020
-FEATURES+=nand
define Target/Description
Build firmware images for Freescale P1020 based boards.