aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorHauke Mehrtens <hauke@hauke-m.de>2022-08-07 14:06:14 +0200
committerHauke Mehrtens <hauke@hauke-m.de>2022-08-14 00:29:19 +0200
commit534e256c029bc47920d8b2544a43e568491b1af2 (patch)
tree25a0fd3447d901595bae9e002e921af982c7faf7
parent2a6fa77b779272ca87e62ef3ae66cb415160d61d (diff)
downloadupstream-534e256c029bc47920d8b2544a43e568491b1af2.tar.gz
upstream-534e256c029bc47920d8b2544a43e568491b1af2.tar.bz2
upstream-534e256c029bc47920d8b2544a43e568491b1af2.zip
kernel: kmod-nft-nat6: Remove package
The nft NAT packages for IPv4 and IPv6 were merged into the common packages with kernel 5.1. The kmod-nft-nat6 package was empty in our build, remove it. Multiple kernel configuration options were also removed, remove them from our generic kernel configuration too. Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de> (cherry picked from commit b75425370d8de747457c137463bc4d15f6f44d00)
-rw-r--r--include/netfilter.mk5
-rw-r--r--package/kernel/linux/modules/netfilter.mk11
-rw-r--r--package/network/config/firewall4/Makefile2
-rw-r--r--target/linux/generic/config-5.103
4 files changed, 1 insertions, 20 deletions
diff --git a/include/netfilter.mk b/include/netfilter.mk
index ffe583f657..ef1fe6df81 100644
--- a/include/netfilter.mk
+++ b/include/netfilter.mk
@@ -340,12 +340,7 @@ $(eval $(if $(NF_KMOD),$(call nf_add,NFT_BRIDGE,CONFIG_NF_CONNTRACK_BRIDGE, $(P_
$(eval $(if $(NF_KMOD),$(call nf_add,NFT_NAT,CONFIG_NFT_NAT, $(P_XT)nft_nat),))
$(eval $(if $(NF_KMOD),$(call nf_add,NFT_NAT,CONFIG_NFT_NAT, $(P_XT)nft_chain_nat),))
-$(eval $(if $(NF_KMOD),$(call nf_add,NFT_NAT,CONFIG_NFT_REDIR_IPV4, $(P_V4)nft_redir_ipv4),))
$(eval $(if $(NF_KMOD),$(call nf_add,NFT_NAT,CONFIG_NFT_MASQ, $(P_XT)nft_masq),))
-$(eval $(if $(NF_KMOD),$(call nf_add,NFT_NAT,CONFIG_NFT_MASQ_IPV4, $(P_V4)nft_masq_ipv4),))
-
-$(eval $(if $(NF_KMOD),$(call nf_add,NFT_NAT6,CONFIG_NFT_REDIR_IPV6, $(P_V6)nft_redir_ipv6),))
-$(eval $(if $(NF_KMOD),$(call nf_add,NFT_NAT6,CONFIG_NFT_MASQ_IPV6, $(P_V6)nft_masq_ipv6),))
$(eval $(if $(NF_KMOD),$(call nf_add,NFT_FIB,CONFIG_NFT_FIB, $(P_XT)nft_fib),))
$(eval $(if $(NF_KMOD),$(call nf_add,NFT_FIB,CONFIG_NFT_FIB_INET, $(P_XT)nft_fib_inet),))
diff --git a/package/kernel/linux/modules/netfilter.mk b/package/kernel/linux/modules/netfilter.mk
index b70c6fa09f..abcbaac54d 100644
--- a/package/kernel/linux/modules/netfilter.mk
+++ b/package/kernel/linux/modules/netfilter.mk
@@ -1187,17 +1187,6 @@ endef
$(eval $(call KernelPackage,nft-offload))
-define KernelPackage/nft-nat6
- SUBMENU:=$(NF_MENU)
- TITLE:=Netfilter nf_tables IPv6-NAT support
- DEPENDS:=+kmod-nft-nat +kmod-nf-nat6
- FILES:=$(foreach mod,$(NFT_NAT6-m),$(LINUX_DIR)/net/$(mod).ko)
- AUTOLOAD:=$(call AutoProbe,$(notdir $(NFT_NAT6-m)))
- KCONFIG:=$(KCONFIG_NFT_NAT6)
-endef
-
-$(eval $(call KernelPackage,nft-nat6))
-
define KernelPackage/nft-netdev
SUBMENU:=$(NF_MENU)
TITLE:=Netfilter nf_tables netdev support
diff --git a/package/network/config/firewall4/Makefile b/package/network/config/firewall4/Makefile
index d6f363f3c8..0003fc09c3 100644
--- a/package/network/config/firewall4/Makefile
+++ b/package/network/config/firewall4/Makefile
@@ -23,7 +23,7 @@ define Package/firewall4
TITLE:=OpenWrt 4th gen firewall
DEPENDS:= \
+kmod-nft-core +kmod-nft-fib +kmod-nft-offload \
- +kmod-nft-nat +kmod-nft-nat6 \
+ +kmod-nft-nat \
+nftables-json \
+ucode +ucode-mod-fs +ucode-mod-ubus +ucode-mod-uci
EXTRA_DEPENDS:=ucode (>= 2022-03-22)
diff --git a/target/linux/generic/config-5.10 b/target/linux/generic/config-5.10
index dac778e073..4529f3888a 100644
--- a/target/linux/generic/config-5.10
+++ b/target/linux/generic/config-5.10
@@ -4126,10 +4126,7 @@ CONFIG_NF_CONNTRACK_PROCFS=y
# CONFIG_NF_NAT_AMANDA is not set
# CONFIG_NF_NAT_FTP is not set
# CONFIG_NF_NAT_H323 is not set
-# CONFIG_NF_NAT_IPV6 is not set
# CONFIG_NF_NAT_IRC is not set
-CONFIG_NF_NAT_MASQUERADE_IPV4=y
-CONFIG_NF_NAT_MASQUERADE_IPV6=y
# CONFIG_NF_NAT_NEEDED is not set
# CONFIG_NF_NAT_PPTP is not set
# CONFIG_NF_NAT_PROTO_GRE is not set