aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMikhail Zhilkin <csharper2005@gmail.com>2022-04-28 18:24:07 +0000
committerPetr Štetiar <ynezz@true.cz>2022-08-16 16:04:55 +0200
commit464f349fadb52456e5d4c51c9b7f48e80f4fc817 (patch)
treea55ae5fae5eb1d33a0507d68ba1c3e5a285f7c38
parent7edaae16db7fd6e1ec0b8aa6d9f20ee1fd7bcc8a (diff)
downloadupstream-464f349fadb52456e5d4c51c9b7f48e80f4fc817.tar.gz
upstream-464f349fadb52456e5d4c51c9b7f48e80f4fc817.tar.bz2
upstream-464f349fadb52456e5d4c51c9b7f48e80f4fc817.zip
ramips: allow custom trx magic for Arcadyan
This commit: 1. Renames beeline-trx recipe in mt7621.mk to arcadyan-trx. The recipe is necessary for: - MTS WG430223 (Arcadyan WG430223) - Beeline Smartbox Flash (Arcadyan WG443223) 2. Allows specify custom trx magic which is different for the routers mentined above. Signed-off-by: Mikhail Zhilkin <csharper2005@gmail.com> (cherry picked from commit 109c503bee9aed34ffb485a29af1e2ec6f3bb6b1) [fix merging conflict in mt7621.mk] Signed-off-by: Mikhail Zhilkin <csharper2005@gmail.com>
-rw-r--r--target/linux/ramips/image/mt7621.mk7
1 files changed, 4 insertions, 3 deletions
diff --git a/target/linux/ramips/image/mt7621.mk b/target/linux/ramips/image/mt7621.mk
index 860b33d1dd..5f6ef8cb76 100644
--- a/target/linux/ramips/image/mt7621.mk
+++ b/target/linux/ramips/image/mt7621.mk
@@ -9,9 +9,10 @@ DEFAULT_SOC := mt7621
KERNEL_DTB += -d21
DEVICE_VARS += ELECOM_HWNAME LINKSYS_HWNAME
-define Build/beeline-trx
+define Build/arcadyan-trx
echo -ne "hsqs" > $@.hsqs
- $(STAGING_DIR_HOST)/bin/otrx create $@.trx -M 0x746f435d -f $@ \
+ $(eval trx_magic=$(word 1,$(1)))
+ $(STAGING_DIR_HOST)/bin/otrx create $@.trx -M $(trx_magic) -f $@ \
-a 0x20000 -b 0x420000 -f $@.hsqs -a 1000
mv $@.trx $@
dd if=/dev/zero bs=1024 count=1 >> $@.tail
@@ -255,7 +256,7 @@ define Device/beeline_smartbox-flash
BLOCKSIZE := 128k
PAGESIZE := 2048
KERNEL := kernel-bin | append-dtb | lzma | loader-kernel | \
- uImage none | beeline-trx | pad-to $$(KERNEL_SIZE)
+ uImage none | arcadyan-trx 0x746f435d | pad-to $$(KERNEL_SIZE)
KERNEL_INITRAMFS := kernel-bin | append-dtb | lzma | loader-kernel | \
uImage none
IMAGES += factory.trx