aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndre Heider <a.heider@gmail.com>2022-07-11 19:49:21 +0200
committerChristian Lamparter <chunkeey@gmail.com>2022-08-06 22:25:43 +0200
commit39ac29a68aba382f052214c18d2da60bd4816fbe (patch)
tree95a38d9f7013999b9695098d4542d94302fed625
parentec8b5cf0e6a858938f409f4bad138a95a1de78e5 (diff)
downloadupstream-39ac29a68aba382f052214c18d2da60bd4816fbe.tar.gz
upstream-39ac29a68aba382f052214c18d2da60bd4816fbe.tar.bz2
upstream-39ac29a68aba382f052214c18d2da60bd4816fbe.zip
uboot-mvebu: update to v2022.07
- Release announcement: https://lore.kernel.org/u-boot/20220711134339.GV1146598@bill-the-cat/ - Changes between 2022.04 and 2022.07: https://source.denx.de/u-boot/u-boot/-/compare/v2022.04...v2022.07?from_project_id=531 Remove one upstreamed patch and add patch to fix issue with sunxi tool as it uses function from newer version libressl (3.5.0). Signed-off-by: Andre Heider <a.heider@gmail.com> Tested-by: Josef Schlehofer <pepe.schlehofer@gmail.com> [Turris Omnia] (cherry picked from commit 24bf6813bad98a8eba5430ed5e4da89d54797274) Signed-off-by: Josef Schlehofer <pepe.schlehofer@gmail.com> [Improve commit message]
-rw-r--r--package/boot/uboot-mvebu/Makefile4
-rw-r--r--package/boot/uboot-mvebu/patches/100-fix-build.patch20
-rw-r--r--package/boot/uboot-mvebu/patches/103-arm-mvebu-clearfog_defconfig-enable-setexpr-command.patch31
3 files changed, 22 insertions, 33 deletions
diff --git a/package/boot/uboot-mvebu/Makefile b/package/boot/uboot-mvebu/Makefile
index 25abcbeb4f..5bf5d59b02 100644
--- a/package/boot/uboot-mvebu/Makefile
+++ b/package/boot/uboot-mvebu/Makefile
@@ -8,10 +8,10 @@
include $(TOPDIR)/rules.mk
include $(INCLUDE_DIR)/kernel.mk
-PKG_VERSION:=2022.04
+PKG_VERSION:=2022.07
PKG_RELEASE:=$(AUTORELEASE)
-PKG_HASH:=68e065413926778e276ec3abd28bb32fa82abaa4a6898d570c1f48fbdb08bcd0
+PKG_HASH:=92b08eb49c24da14c1adbf70a71ae8f37cc53eeb4230e859ad8b6733d13dcf5e
include $(INCLUDE_DIR)/u-boot.mk
include $(INCLUDE_DIR)/package.mk
diff --git a/package/boot/uboot-mvebu/patches/100-fix-build.patch b/package/boot/uboot-mvebu/patches/100-fix-build.patch
new file mode 100644
index 0000000000..c39f5bf1dc
--- /dev/null
+++ b/package/boot/uboot-mvebu/patches/100-fix-build.patch
@@ -0,0 +1,20 @@
+The build fails on a sunxi tool:
+
+/usr/bin/ld: tools/sunxi_toc0.o: in function `toc0_set_header':
+sunxi_toc0.c:(.text+0x363): undefined reference to `RSA_get0_d'
+
+The missing function was added in libressl v3.5.0. We don't
+really care, so just cut it out for now.
+
+--- a/tools/Makefile
++++ b/tools/Makefile
+@@ -96,8 +96,7 @@ AES_OBJS-$(CONFIG_TOOLS_LIBCRYPTO) := $(
+
+ # Cryptographic helpers and image types that depend on openssl/libcrypto
+ LIBCRYPTO_OBJS-$(CONFIG_TOOLS_LIBCRYPTO) := \
+- lib/fdt-libcrypto.o \
+- sunxi_toc0.o
++ lib/fdt-libcrypto.o
+
+ ROCKCHIP_OBS = lib/rc4.o rkcommon.o rkimage.o rksd.o rkspi.o
+
diff --git a/package/boot/uboot-mvebu/patches/103-arm-mvebu-clearfog_defconfig-enable-setexpr-command.patch b/package/boot/uboot-mvebu/patches/103-arm-mvebu-clearfog_defconfig-enable-setexpr-command.patch
deleted file mode 100644
index dae43ea942..0000000000
--- a/package/boot/uboot-mvebu/patches/103-arm-mvebu-clearfog_defconfig-enable-setexpr-command.patch
+++ /dev/null
@@ -1,31 +0,0 @@
-From 40a67a9403deafdac05564b7350af49a71e12373 Mon Sep 17 00:00:00 2001
-From: Josef Schlehofer <pepe.schlehofer@gmail.com>
-Date: Fri, 29 Apr 2022 17:34:53 +0200
-Subject: [PATCH] arm: mvebu: clearfog_defconfig: enable setexpr command
-
-This command is useful in U-boot scripts and it is being used by
-OpenWrt bootscript for this board [1]. Otherwise shell scripting
-commands are enabled by default in cmd/Kconfig.
-
-[1] https://github.com/openwrt/openwrt/blob/852126680e21edc71c0c66561ae5a6d7479dcc67/target/linux/mvebu/image/clearfog.bootscript#L7
-
-[2] https://source.denx.de/u-boot/u-boot/-/blob/e95afa56753cebcd20a5114b6d121f281b789006/cmd/Kconfig#L1504
-
-Fixes: 0299c90f396c5b2971a4bac596339f4b03661c27 ("arm: mvebu: Add
-SolidRun ClearFog Armada 38x initial support")
-
-Signed-off-by: Josef Schlehofer <pepe.schlehofer@gmail.com>
----
- configs/clearfog_defconfig | 1 -
- 1 file changed, 1 deletion(-)
-
---- a/configs/clearfog_defconfig
-+++ b/configs/clearfog_defconfig
-@@ -35,7 +35,6 @@ CONFIG_CMD_MMC=y
- CONFIG_CMD_PCI=y
- CONFIG_CMD_SPI=y
- CONFIG_CMD_USB=y
--# CONFIG_CMD_SETEXPR is not set
- CONFIG_CMD_TFTPPUT=y
- CONFIG_CMD_CACHE=y
- CONFIG_CMD_TIME=y