aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLech Perczak <lech.perczak@gmail.com>2022-08-10 01:06:24 +0200
committerHauke Mehrtens <hauke@hauke-m.de>2022-08-14 21:06:53 +0200
commit2728d13030ac8fb8235875204e44be7e6ba8aecb (patch)
treee0967a99806a6834ecf8ac7ca78a632da099d35d
parent46e62907f1dafa02fd117bbdccd9521b13a3acf4 (diff)
downloadupstream-2728d13030ac8fb8235875204e44be7e6ba8aecb.tar.gz
upstream-2728d13030ac8fb8235875204e44be7e6ba8aecb.tar.bz2
upstream-2728d13030ac8fb8235875204e44be7e6ba8aecb.zip
ath25: fix ELF image generation
Commit 21f460a5dbef ("ath25: fix duplicate LZMA compression"), when attempting to restore ELF artifact generation, copiedover the raw kernel image twice. Because of that, the .elf artifact was actually a duplicate of raw image. Fix that by copying over .elf suffixed kernel image instead. Fixes: 21f460a5dbef ("ath25: fix duplicate LZMA compression") Signed-off-by: Lech Perczak <lech.perczak@gmail.com> (cherry picked from commit 611291383a826827f240eddebca1949c2e1e7115)
-rw-r--r--target/linux/ath25/image/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/target/linux/ath25/image/Makefile b/target/linux/ath25/image/Makefile
index 2b22d54105..d6cd53d261 100644
--- a/target/linux/ath25/image/Makefile
+++ b/target/linux/ath25/image/Makefile
@@ -43,7 +43,7 @@ endef
define Build/copy-kernel
rm -f $@ $@.elf
cp $< $@
- cp $< $@.elf
+ cp $<.elf $@.elf
endef
define Build/elf-kernel