aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLech Perczak <lech.perczak@gmail.com>2022-08-10 01:10:57 +0200
committerHauke Mehrtens <hauke@hauke-m.de>2022-08-14 21:06:53 +0200
commit1d16b928b3bebedac7d5bf783a8f219156131abe (patch)
tree02309d770cf770ca828ebb9faa53c99b3dcca09d
parent2728d13030ac8fb8235875204e44be7e6ba8aecb (diff)
downloadupstream-1d16b928b3bebedac7d5bf783a8f219156131abe.tar.gz
upstream-1d16b928b3bebedac7d5bf783a8f219156131abe.tar.bz2
upstream-1d16b928b3bebedac7d5bf783a8f219156131abe.zip
ath25: fix initramfs image generation
Commit 21f460a5dbef ("ath25: fix duplicate LZMA compression") changed the way kernel images are generated, affecting initramfs images instead. Initramfs images were previously ELF images, and by mistake this change caused the raw kernel image to be used as a source. This caused them to be non-loadable by bootloaders. Restore the previous KERNEL_INITRAMFS recipe and adjust KERNEL_INITRAMFS_NAME to point at the correct source artifact. While at that, adjust KERNEL_INITRAMFS_SUFFIX to -kernel.elf, so it matches the suffix of non-initramfs kernel artifact. Fixes: 21f460a5dbef ("ath25: fix duplicate LZMA compression") Signed-off-by: Lech Perczak <lech.perczak@gmail.com> (cherry picked from commit 9f5cbb6e8b9537942db405719bf7662d0e08b8c5)
-rw-r--r--target/linux/ath25/image/Makefile3
1 files changed, 3 insertions, 0 deletions
diff --git a/target/linux/ath25/image/Makefile b/target/linux/ath25/image/Makefile
index d6cd53d261..9cdcdf9e95 100644
--- a/target/linux/ath25/image/Makefile
+++ b/target/linux/ath25/image/Makefile
@@ -54,6 +54,9 @@ endef
define Device/Default
PROFILES = Default $$(DEVICE_NAME)
KERNEL := copy-kernel | lzma-kernel
+ KERNEL_INITRAMFS = kernel-bin
+ KERNEL_INITRAMFS_NAME := vmlinux-initramfs.elf
+ KERNEL_INITRAMFS_SUFFIX := -kernel.elf
IMAGES := sysupgrade.bin
FILESYSTEMS := squashfs
endef