aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorBaptiste Jonglez <git@bitsofnetworks.org>2017-02-12 14:48:35 +0100
committerFelix Fietkau <nbd@nbd.name>2017-02-12 14:53:29 +0100
commitf938de791438fc932c5a5ccfecd8f33050e3e103 (patch)
treec7772019e6ed0f18ec1ad52c6c8d758cb756ca20
parent764cd09dd845864b0d45c6b1f914b81612a5dd28 (diff)
downloadupstream-f938de791438fc932c5a5ccfecd8f33050e3e103.tar.gz
upstream-f938de791438fc932c5a5ccfecd8f33050e3e103.tar.bz2
upstream-f938de791438fc932c5a5ccfecd8f33050e3e103.zip
build: fix dependency of kernel_menuconfig target
When running "make kernel_menuconfig" in a clean tree, it fails with: make[1]: *** No rule to make target 'tools/quilt/install'. Stop. Replacing the dependency with 'tools/quilt/compile' fixes the issue (quilt and all its prerequisites will be built, and quilt will be installed in staging_dir). Signed-off-by: Baptiste Jonglez <git@bitsofnetworks.org>
-rw-r--r--include/toplevel.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/include/toplevel.mk b/include/toplevel.mk
index 24e4ebf823..a9ea21bbef 100644
--- a/include/toplevel.mk
+++ b/include/toplevel.mk
@@ -132,7 +132,7 @@ prepare_kernel_conf: .config FORCE
ifeq ($(wildcard staging_dir/host/bin/quilt),)
prepare_kernel_conf:
- @+$(SUBMAKE) -r tools/quilt/install
+ @+$(SUBMAKE) -r tools/quilt/compile
else
prepare_kernel_conf: ;
endif
erty */ .highlight .nt { color: #bb0066; font-weight: bold } /* Name.Tag */ .highlight .nv { color: #336699 } /* Name.Variable */ .highlight .ow { color: #008800 } /* Operator.Word */ .highlight .w { color: #bbbbbb } /* Text.Whitespace */ .highlight .mb { color: #0000DD; font-weight: bold } /* Literal.Number.Bin */ .highlight .mf { color: #0000DD; font-weight: bold } /* Literal.Number.Float */ .highlight .mh { color: #0000DD; font-weight: bold } /* Literal.Number.Hex */ .highlight .mi { color: #0000DD; font-weight: bold } /* Literal.Number.Integer */ .highlight .mo { color: #0000DD; font-weight: bold } /* Literal.Number.Oct */ .highlight .sa { color: #dd2200; background-color: #fff0f0 } /* Literal.String.Affix */ .highlight .sb { color: #dd2200; background-color: #fff0f0 } /* Literal.String.Backtick */ .highlight .sc { color: #dd2200; background-color: #fff0f0 } /* Literal.String.Char */ .highlight .dl { color: #dd2200; background-color: #fff0f0 } /* Literal.String.Delimiter */ .highlight .sd { color: #dd2200; background-color: #fff0f0 } /* Literal.String.Doc */ .highlight .s2 { color: #dd2200; background-color: #fff0f0 } /* Literal.String.Double */ .highlight .se { color: #0044dd; background-color: #fff0f0 } /* Literal.String.Escape */ .highlight .sh { color: #dd2200; background-color: #fff0f0 } /* Literal.String.Heredoc */ .highlight .si { color: #3333bb; background-color: #fff0f0 } /* Literal.String.Interpol */ .highlight .sx { color: #22bb22; background-color: #f0fff0 } /* Literal.String.Other */ .highlight .sr { color: #008800; background-color: #fff0ff } /* Literal.String.Regex */ .highlight .s1 { color: #dd2200; background-color: #fff0f0 } /* Literal.String.Single */ .highlight .ss { color: #aa6600; background-color: #fff0f0 } /* Literal.String.Symbol */ .highlight .bp { color: #003388 } /* Name.Builtin.Pseudo */ .highlight .fm { color: #0066bb; font-weight: bold } /* Name.Function.Magic */ .highlight .vc { color: #336699 } /* Name.Variable.Class */ .highlight .vg { color: #dd7700 } /* Name.Variable.Global */ .highlight .vi { color: #3333bb } /* Name.Variable.Instance */ .highlight .vm { color: #336699 } /* Name.Variable.Magic */ .highlight .il { color: #0000DD; font-weight: bold } /* Literal.Number.Integer.Long */
choice
	prompt "eglibc version" 
	depends on TOOLCHAINOPTS && USE_EGLIBC
	default EGLIBC_VERSION_2_8
	help
	  Select the version of eglibc you wish to use.

	config EGLIBC_VERSION_2_6
		bool "eglibc 2.6"

	config EGLIBC_VERSION_2_7
		bool "eglibc 2.7"

	config EGLIBC_VERSION_2_8
		bool "eglibc 2.8"

	config EGLIBC_VERSION_2_9
		bool "eglibc 2.9"

	config EGLIBC_VERSION_2_10
		bool "eglibc 2.10"

	config EGLIBC_VERSION_2_11
		bool "eglibc 2.11"
		depends GCC_VERSION_4_3 || GCC_VERSION_4_4

	config EGLIBC_VERSION_TRUNK
		bool "eglibc trunk"

endchoice

config EGLIBC_REVISION
	string
	prompt "eglibc revision"
	depends on TOOLCHAINOPTS && USE_EGLIBC
	default "5887"  if EGLIBC_VERSION_2_6
	default "8588"  if EGLIBC_VERSION_2_7
	default "8587"  if EGLIBC_VERSION_2_8
	default "8690"  if EGLIBC_VERSION_2_9
	default "9289"  if EGLIBC_VERSION_2_10
	default "9306"  if EGLIBC_VERSION_2_11
	default "HEAD"  if EGLIBC_VERSION_TRUNK
	default ""

menu "eglibc configuration"
	depends on TOOLCHAINOPTS && USE_EGLIBC
	source toolchain/eglibc/config/Config.in
endmenu