aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorHauke Mehrtens <hauke@hauke-m.de>2022-05-30 08:45:46 -0400
committerHauke Mehrtens <hauke@hauke-m.de>2022-07-04 01:35:37 +0200
commit3439c2ff7092d193bd27dae0ecf7f2071683ce68 (patch)
tree42e532aacbf0fee98668725ab94b06201244f94d
parent8001e1995539526e873764bcedcff6aa69f1ee9f (diff)
downloadupstream-3439c2ff7092d193bd27dae0ecf7f2071683ce68.tar.gz
upstream-3439c2ff7092d193bd27dae0ecf7f2071683ce68.tar.bz2
upstream-3439c2ff7092d193bd27dae0ecf7f2071683ce68.zip
kernel: Remove kmod-crypto-lib-blake2s
Delete the crypto-lib-blake2s kmod package, as BLAKE2s is now built-in. Fixes: be0639063a70 ("kernel: bump 5.4 to 5.4.203") Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
-rw-r--r--package/kernel/linux/modules/crypto.mk22
-rw-r--r--package/kernel/linux/modules/netsupport.mk1
-rw-r--r--target/linux/generic/config-5.41
-rw-r--r--target/linux/x86/64/config-5.41
4 files changed, 1 insertions, 24 deletions
diff --git a/package/kernel/linux/modules/crypto.mk b/package/kernel/linux/modules/crypto.mk
index b50ed06824..4e0a73ccf2 100644
--- a/package/kernel/linux/modules/crypto.mk
+++ b/package/kernel/linux/modules/crypto.mk
@@ -440,28 +440,6 @@ endef
$(eval $(call KernelPackage,crypto-kpp))
-define KernelPackage/crypto-lib-blake2s
- TITLE:=BLAKE2s hash function library
- KCONFIG:=CONFIG_CRYPTO_LIB_BLAKE2S
- HIDDEN:=1
- FILES:= \
- $(LINUX_DIR)/lib/crypto/libblake2s.ko \
- $(LINUX_DIR)/lib/crypto/libblake2s-generic.ko
- $(call AddDepends/crypto,+PACKAGE_kmod-crypto-hash:kmod-crypto-hash)
-endef
-
-define KernelPackage/crypto-lib-blake2s/config
- imply PACKAGE_kmod-crypto-hash
-endef
-
-define KernelPackage/crypto-lib-blake2s/x86/64
- KCONFIG+=CONFIG_CRYPTO_BLAKE2S_X86
- FILES+=$(LINUX_DIR)/arch/x86/crypto/blake2s-x86_64.ko
-endef
-
-$(eval $(call KernelPackage,crypto-lib-blake2s))
-
-
define KernelPackage/crypto-lib-chacha20
TITLE:=ChaCha library interface
KCONFIG:=CONFIG_CRYPTO_LIB_CHACHA
diff --git a/package/kernel/linux/modules/netsupport.mk b/package/kernel/linux/modules/netsupport.mk
index 1eec9f9b63..4c84bea9bb 100644
--- a/package/kernel/linux/modules/netsupport.mk
+++ b/package/kernel/linux/modules/netsupport.mk
@@ -1263,7 +1263,6 @@ define KernelPackage/wireguard
SUBMENU:=$(NETWORK_SUPPORT_MENU)
TITLE:=WireGuard secure network tunnel
DEPENDS:= \
- +kmod-crypto-lib-blake2s \
+kmod-crypto-lib-chacha20poly1305 \
+kmod-crypto-lib-curve25519 \
+kmod-udptunnel4 \
diff --git a/target/linux/generic/config-5.4 b/target/linux/generic/config-5.4
index 3517ece49c..f205921c17 100644
--- a/target/linux/generic/config-5.4
+++ b/target/linux/generic/config-5.4
@@ -1069,7 +1069,6 @@ CONFIG_CRYPTO_BLKCIPHER2=y
# CONFIG_CRYPTO_KHAZAD is not set
CONFIG_CRYPTO_LIB_AES=y
CONFIG_CRYPTO_LIB_ARC4=y
-# CONFIG_CRYPTO_LIB_BLAKE2S is not set
# CONFIG_CRYPTO_LIB_CHACHA is not set
# CONFIG_CRYPTO_LIB_CHACHA20POLY1305 is not set
# CONFIG_CRYPTO_LIB_CURVE25519 is not set
diff --git a/target/linux/x86/64/config-5.4 b/target/linux/x86/64/config-5.4
index 434cde5d86..519ae961e0 100644
--- a/target/linux/x86/64/config-5.4
+++ b/target/linux/x86/64/config-5.4
@@ -82,6 +82,7 @@ CONFIG_CRC_T10DIF=y
CONFIG_CRYPTO_AEAD=y
CONFIG_CRYPTO_AEAD2=y
CONFIG_CRYPTO_AES_NI_INTEL=y
+CONFIG_CRYPTO_BLAKE2S_X86=y
# CONFIG_CRYPTO_BLOWFISH_X86_64 is not set
# CONFIG_CRYPTO_CAMELLIA_AESNI_AVX2_X86_64 is not set
# CONFIG_CRYPTO_CAMELLIA_AESNI_AVX_X86_64 is not set