diff options
author | Felix Fietkau <nbd@nbd.name> | 2017-02-07 10:33:10 +0100 |
---|---|---|
committer | Felix Fietkau <nbd@nbd.name> | 2017-02-07 17:18:15 +0100 |
commit | f55c29e4c74353ef0795eb83911c708c6db90466 (patch) | |
tree | 12a376221eb213206d2e23159f3492da0b69ef65 | |
parent | fa8506069833b8616dafe921c1d6e20a24b77217 (diff) | |
download | upstream-f55c29e4c74353ef0795eb83911c708c6db90466.tar.gz upstream-f55c29e4c74353ef0795eb83911c708c6db90466.tar.bz2 upstream-f55c29e4c74353ef0795eb83911c708c6db90466.zip |
build: remove libc version suffix from build/staging directories
Our supported libcs are ABI compatible across version upgrades
Signed-off-by: Felix Fietkau <nbd@nbd.name>
-rw-r--r-- | rules.mk | 3 | ||||
-rwxr-xr-x | scripts/remote-gdb | 4 |
2 files changed, 3 insertions, 4 deletions
@@ -120,10 +120,9 @@ BUILD_DIR_BASE:=$(TOPDIR)/build_dir ifeq ($(CONFIG_EXTERNAL_TOOLCHAIN),) GCCV:=$(call qstrip,$(CONFIG_GCC_VERSION)) LIBC:=$(call qstrip,$(CONFIG_LIBC)) - LIBCV:=$(call qstrip,$(CONFIG_LIBC_VERSION)) REAL_GNU_TARGET_NAME=$(OPTIMIZE_FOR_CPU)-openwrt-linux$(if $(TARGET_SUFFIX),-$(TARGET_SUFFIX)) GNU_TARGET_NAME=$(OPTIMIZE_FOR_CPU)-openwrt-linux - DIR_SUFFIX:=_$(LIBC)-$(LIBCV)$(if $(CONFIG_arm),_eabi) + DIR_SUFFIX:=_$(LIBC)$(if $(CONFIG_arm),_eabi) BIN_DIR:=$(BIN_DIR)$(if $(CONFIG_USE_MUSL),,-$(LIBC)) TARGET_DIR_NAME = target-$(ARCH)$(ARCH_SUFFIX)$(DIR_SUFFIX)$(if $(BUILD_SUFFIX),_$(BUILD_SUFFIX)) TOOLCHAIN_DIR_NAME = toolchain-$(ARCH)$(ARCH_SUFFIX)_gcc-$(GCCV)$(DIR_SUFFIX) diff --git a/scripts/remote-gdb b/scripts/remote-gdb index efb321c243..99c9d386d3 100755 --- a/scripts/remote-gdb +++ b/scripts/remote-gdb @@ -14,7 +14,7 @@ if( opendir SD, "$Bin/../staging_dir" ) { my ( $tid, $arch, $libc, @arches ); - if( $ARGV[1] =~ m!\btarget-(.+?)_(([^/_]+libc|musl)[^/_]+)\b!i ) + if( $ARGV[1] =~ m!\btarget-(.+?)_(([^/_]+libc|musl)[^/_]*)\b!i ) { print("Using target $1 ($2)\n"); ($arch, $libc) = ($1, $2); @@ -26,7 +26,7 @@ if( opendir SD, "$Bin/../staging_dir" ) while( defined( my $e = readdir SD ) ) { - if( -d "$Bin/../staging_dir/$e" && $e =~ /^target-(.+?)_(([^_]+libc|musl).+)/i ) + if( -d "$Bin/../staging_dir/$e" && $e =~ /^target-(.+?)_(([^_]+libc|musl).*)/i ) { push @arches, [ $1, $2 ]; printf(" %2d) %s (%s)\n", @arches + 0, $1, $2); |