diff options
author | Felix Fietkau <nbd@openwrt.org> | 2007-11-04 11:42:47 +0000 |
---|---|---|
committer | Felix Fietkau <nbd@openwrt.org> | 2007-11-04 11:42:47 +0000 |
commit | db87e1f8c14fcdc6ea0da199f8e9dd1b7209c102 (patch) | |
tree | 6f4b96fcd063a2aa46787d62d5cdfb04f40ffb8a | |
parent | fcdf364d10cf68fc0578446b096b0f5ce38eb6c1 (diff) | |
download | upstream-db87e1f8c14fcdc6ea0da199f8e9dd1b7209c102.tar.gz upstream-db87e1f8c14fcdc6ea0da199f8e9dd1b7209c102.tar.bz2 upstream-db87e1f8c14fcdc6ea0da199f8e9dd1b7209c102.zip |
fix parallel build issues
SVN-Revision: 9495
-rw-r--r-- | Makefile | 12 | ||||
-rw-r--r-- | include/toplevel.mk | 1 |
2 files changed, 8 insertions, 5 deletions
@@ -9,8 +9,7 @@ TOPDIR:=${CURDIR} LC_ALL:=C LANG:=C -IS_TTY:=${shell tty -s && echo 1 || echo 0} -export TOPDIR LC_ALL LANG IS_TTY +export TOPDIR LC_ALL LANG world: @@ -31,10 +30,13 @@ else include tools/Makefile include toolchain/Makefile -$(toolchain/stamp-compile): $(tools/stamp-compile) +$(toolchain/stamp-install): $(tools/stamp-install) $(target/stamp-compile): $(toolchain/stamp-install) $(tools/stamp-install) $(BUILD_DIR)/.prepared -$(package/stamp-compile): $(target/stamp-compile) -$(target/stamp-install): $(package/stamp-compile) $(package/stamp-install) +$(package/stamp-cleanup): $(target/stamp-compile) +$(package/stamp-compile): $(target/stamp-compile) $(package/stamp-cleanup) +$(package/stamp-install): $(package/stamp-compile) +$(package/stamp-rootfs-prepare): $(package/stamp-install) +$(target/stamp-install): $(package/stamp-compile) $(package/stamp-install) $(package/stamp-rootfs-prepare) $(BUILD_DIR)/.prepared: Makefile @mkdir -p $$(dirname $@) diff --git a/include/toplevel.mk b/include/toplevel.mk index ba5cb33759..7930223650 100644 --- a/include/toplevel.mk +++ b/include/toplevel.mk @@ -22,6 +22,7 @@ else endif endif export OPENWRTVERSION +export IS_TTY=$(shell tty -s && echo 1 || echo 0) ifeq ($(FORCE),) .config scripts/config/conf scripts/config/mconf: tmp/.prereq-build |