aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRafał Miłecki <rafal@milecki.pl>2021-01-13 09:16:46 +0100
committerRafał Miłecki <rafal@milecki.pl>2021-01-15 07:45:19 +0100
commitc40006e0af4bd58670cc8c413065830365039fe0 (patch)
tree1d7c207bc726b0481cb4c60507500a7662ada7e0
parent6e7ca70449f2fb10007918cdd4616c556ccc2ae1 (diff)
downloadupstream-c40006e0af4bd58670cc8c413065830365039fe0.tar.gz
upstream-c40006e0af4bd58670cc8c413065830365039fe0.tar.bz2
upstream-c40006e0af4bd58670cc8c413065830365039fe0.zip
bcm4908: prepend kernel images with a custom header
It's required for CFE to accept kernel. Signed-off-by: Rafał Miłecki <rafal@milecki.pl>
-rw-r--r--target/linux/bcm4908/image/Makefile9
1 files changed, 7 insertions, 2 deletions
diff --git a/target/linux/bcm4908/image/Makefile b/target/linux/bcm4908/image/Makefile
index 7eaafd583c..f5db38915d 100644
--- a/target/linux/bcm4908/image/Makefile
+++ b/target/linux/bcm4908/image/Makefile
@@ -8,11 +8,16 @@ define Build/bcm4908lzma
mv $@.new $@
endef
+define Build/bcm4908kernel
+ $(STAGING_DIR_HOST)/bin/bcm4908kernel -i $@ -o $@.new
+ mv $@.new $@
+endef
+
define Device/Default
- KERNEL := kernel-bin | bcm4908lzma
+ KERNEL := kernel-bin | bcm4908lzma | bcm4908kernel
KERNEL_DEPENDS = $$(wildcard $(DTS_DIR)/$$(DEVICE_DTS).dts)
KERNEL_INITRAMFS_SUFFIX := .bin
- KERNEL_INITRAMFS := kernel-bin | bcm4908lzma
+ KERNEL_INITRAMFS := kernel-bin | bcm4908lzma | bcm4908kernel
FILESYSTEMS := squashfs
KERNEL_NAME := Image
IMAGE_NAME = $$(IMAGE_PREFIX)-$$(1).$$(2)