aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJohn Crispin <john@phrozen.org>2021-06-03 15:57:07 +0200
committerPetr Štetiar <ynezz@true.cz>2022-02-26 09:27:15 +0100
commitabf8209d7f200fd9cd732a2d535699830d89f57c (patch)
treede277104345c59a76aa92842d97edfeb23422894
parent610b2cff606cdaa7739e38f10b004727acd6cdbf (diff)
downloadupstream-abf8209d7f200fd9cd732a2d535699830d89f57c.tar.gz
upstream-abf8209d7f200fd9cd732a2d535699830d89f57c.tar.bz2
upstream-abf8209d7f200fd9cd732a2d535699830d89f57c.zip
hostapd: fix radius problem due to invalid attributes
The offending commit caused the configuration file to contain: radius_auth_req_attr= radius_acct_req_attr= which cause hostapd to add an ATTR of type 0 into the messages. hostapd: RADIUS message: code=4 (Accounting-Request) identifier=0 length=93 hostapd: Attribute 40 (Acct-Status-Type) length=6 hostapd: Value: 7 hostapd: Attribute 30 (Called-Station-Id) length=28 hostapd: Value: 'C4-41-1E-F5-2D-55:OpenWifi' hostapd: Attribute 61 (NAS-Port-Type) length=6 hostapd: Value: 19 hostapd: Attribute 0 (?Unknown?) length=3 <---------------- hostapd: Attribute 55 (Event-Timestamp) length=6 hostapd: Value: 1622726457 hostapd: Attribute 41 (Acct-Delay-Time) length=6 hostapd: Value: 0 hostapd: Attribute 44 (Acct-Session-Id) length=18 hostapd: Value: '9B5961E7235AAEC6' Closes: #9315 Fixes: ce7a17041486 ("hostapd: add additional radius options") Signed-off-by: John Crispin <john@phrozen.org> Signed-off-by: Petr Štetiar <ynezz@true.cz> [pkg version bump] (cherry picked from commit 96e9c81aabe9e14d6ec75c3f238c4ca7389b92a8)
-rw-r--r--package/network/services/hostapd/Makefile2
-rw-r--r--package/network/services/hostapd/files/hostapd.sh4
2 files changed, 3 insertions, 3 deletions
diff --git a/package/network/services/hostapd/Makefile b/package/network/services/hostapd/Makefile
index d1ca7ba8b6..e529a2efd3 100644
--- a/package/network/services/hostapd/Makefile
+++ b/package/network/services/hostapd/Makefile
@@ -7,7 +7,7 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=hostapd
-PKG_RELEASE:=39
+PKG_RELEASE:=40
PKG_SOURCE_URL:=http://w1.fi/hostap.git
PKG_SOURCE_PROTO:=git
diff --git a/package/network/services/hostapd/files/hostapd.sh b/package/network/services/hostapd/files/hostapd.sh
index b52667d09a..e47ae46f98 100644
--- a/package/network/services/hostapd/files/hostapd.sh
+++ b/package/network/services/hostapd/files/hostapd.sh
@@ -488,11 +488,11 @@ append_hs20_conn_capab() {
}
append_radius_acct_req_attr() {
- append bss_conf "radius_acct_req_attr=$1" "$N"
+ [ -n "$1" ] && append bss_conf "radius_acct_req_attr=$1" "$N"
}
append_radius_auth_req_attr() {
- append bss_conf "radius_auth_req_attr=$1" "$N"
+ [ -n "$1" ] && append bss_conf "radius_auth_req_attr=$1" "$N"
}
append_airtime_sta_weight() {