aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorPetr Štetiar <ynezz@true.cz>2022-03-24 06:52:37 +0100
committerPetr Štetiar <ynezz@true.cz>2022-04-05 22:06:41 +0200
commit3008f1f441a41e162311cee1ccadfdaaec1581c1 (patch)
treed3f2a1ddfdc691fb1b96b44c9f814f99854faf78
parentee62912b2db0018cd370f2c110e1391ee779cc6d (diff)
downloadupstream-3008f1f441a41e162311cee1ccadfdaaec1581c1.tar.gz
upstream-3008f1f441a41e162311cee1ccadfdaaec1581c1.tar.bz2
upstream-3008f1f441a41e162311cee1ccadfdaaec1581c1.zip
imagebuilder: fix broken image generation with external targets
When using external targets there is a symlink being created for the target under target/linux which then becomes dangling under Image Builder. Fix it by dereferencing the possible symlink. Tested on IB with external target, ipq40xx and mvebu. Signed-off-by: Petr Štetiar <ynezz@true.cz> (cherry picked from commit 621f39d1f438bf95dbae667c575926fa16a6d797) (cherry picked from commit ec9af870f3278f75549836b469baefa260e2ed41)
-rw-r--r--target/imagebuilder/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/target/imagebuilder/Makefile b/target/imagebuilder/Makefile
index 8607a2d709..3bbadc7204 100644
--- a/target/imagebuilder/Makefile
+++ b/target/imagebuilder/Makefile
@@ -78,7 +78,7 @@ ifneq ($(CONFIG_SIGNATURE_CHECK),)
$(CP) -L $(STAGING_DIR_ROOT)/usr/sbin/opkg-key $(PKG_BUILD_DIR)/scripts/
endif
- $(CP) $(TOPDIR)/target/linux $(PKG_BUILD_DIR)/target/
+ $(CP) -L $(TOPDIR)/target/linux $(PKG_BUILD_DIR)/target/
if [ -d $(TOPDIR)/staging_dir/host/lib/grub ]; then \
$(CP) $(TOPDIR)/staging_dir/host/lib/grub/ $(PKG_BUILD_DIR)/staging_dir/host/lib; \
fi