aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorShiji Yang <yangshiji66@qq.com>2021-05-16 21:21:09 +0800
committerPetr Štetiar <ynezz@true.cz>2022-04-19 14:48:21 +0200
commit92af15077f37af561ca31e22d7c9bdc2096cc10c (patch)
tree5c98fb0768376f4d9a9fad9f0acf642049aa9d8e
parent55f8eb84d2e4a52186a9c6fa4ec67cf60fcb2977 (diff)
downloadupstream-92af15077f37af561ca31e22d7c9bdc2096cc10c.tar.gz
upstream-92af15077f37af561ca31e22d7c9bdc2096cc10c.tar.bz2
upstream-92af15077f37af561ca31e22d7c9bdc2096cc10c.zip
ramips: split Youku YK1 to YK-L1 and YK-L1c
Device specifications: * Model: Youku YK-L1/L1c * CPU: MT7620A * RAM: 128 MiB * Flash: 32 MiB (YK-L1)/ 16 MiB (YK-L1c) * LAN: 2* 10M/100M Ports * WAN: 1* 10M/100M Port * USB: 1* USB2.0 * SD: 1* MicroSD socket * UART: 1* TTL, Baudrate 57600 Descriptions: Previous supported device YOUKU yk1 is actually Youku YK-L1. Though they look really different, the only hardware difference between the two models is flash size, YK-L1 has 32 MiB flash but YK-L1c has 16MiB. It seems that YK-L1c can compatible with YK-L1's firmware but it's better to split it to different models. It is easy to identify the models by looking at the label on the bottom of the device. The label has the model number "YK-L1" or "YK-L1c". Due to different flash sizes, YK-L1c that using previous YK-L1's firmware needs to apply "force update" to install compatible firmware, so please backup config file before system upgrade. Signed-off-by: Shiji Yang <yangshiji66@qq.com> [use more specific name for DTSI] Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de> (cherry picked from commit 4a9f389ed2dcee18a5c5e1f0d4e5c406f9290579)
-rw-r--r--target/linux/ramips/dts/mt7620a_youku_yk-l1.dts12
-rw-r--r--target/linux/ramips/dts/mt7620a_youku_yk-l1.dtsi (renamed from target/linux/ramips/dts/mt7620a_youku_yk1.dts)7
-rw-r--r--target/linux/ramips/dts/mt7620a_youku_yk-l1c.dts12
-rw-r--r--target/linux/ramips/image/mt7620.mk20
-rwxr-xr-xtarget/linux/ramips/mt7620/base-files/etc/board.d/02_network6
5 files changed, 45 insertions, 12 deletions
diff --git a/target/linux/ramips/dts/mt7620a_youku_yk-l1.dts b/target/linux/ramips/dts/mt7620a_youku_yk-l1.dts
new file mode 100644
index 0000000000..5155318b0c
--- /dev/null
+++ b/target/linux/ramips/dts/mt7620a_youku_yk-l1.dts
@@ -0,0 +1,12 @@
+// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
+
+#include "mt7620a_youku_yk-l1.dtsi"
+
+/ {
+ compatible = "youku,yk-l1", "ralink,mt7620a-soc";
+ model = "Youku YK-L1";
+};
+
+&firmware {
+ reg = <0x50000 0x1fb0000>;
+};
diff --git a/target/linux/ramips/dts/mt7620a_youku_yk1.dts b/target/linux/ramips/dts/mt7620a_youku_yk-l1.dtsi
index 2e59e5bf6e..61062a3179 100644
--- a/target/linux/ramips/dts/mt7620a_youku_yk1.dts
+++ b/target/linux/ramips/dts/mt7620a_youku_yk-l1.dtsi
@@ -4,9 +4,6 @@
#include <dt-bindings/input/input.h>
/ {
- compatible = "youku,yk1", "ralink,mt7620a-soc";
- model = "YOUKU YK1";
-
aliases {
led-boot = &led_power;
led-failsafe = &led_power;
@@ -88,10 +85,10 @@
read-only;
};
- partition@50000 {
+ firmware: partition@50000 {
compatible = "denx,uimage";
label = "firmware";
- reg = <0x50000 0x1fb0000>;
+ /* reg property is set based on flash size in DTS files */
};
};
};
diff --git a/target/linux/ramips/dts/mt7620a_youku_yk-l1c.dts b/target/linux/ramips/dts/mt7620a_youku_yk-l1c.dts
new file mode 100644
index 0000000000..c59f0101bd
--- /dev/null
+++ b/target/linux/ramips/dts/mt7620a_youku_yk-l1c.dts
@@ -0,0 +1,12 @@
+// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
+
+#include "mt7620a_youku_yk-l1.dtsi"
+
+/ {
+ compatible = "youku,yk-l1c", "ralink,mt7620a-soc";
+ model = "Youku YK-L1c";
+};
+
+&firmware {
+ reg = <0x50000 0xfb0000>;
+};
diff --git a/target/linux/ramips/image/mt7620.mk b/target/linux/ramips/image/mt7620.mk
index 56941f2b9c..4f85b82c0e 100644
--- a/target/linux/ramips/image/mt7620.mk
+++ b/target/linux/ramips/image/mt7620.mk
@@ -1113,16 +1113,26 @@ define Device/xiaomi_miwifi-mini
endef
TARGET_DEVICES += xiaomi_miwifi-mini
-define Device/youku_yk1
+define Device/youku_yk-l1
SOC := mt7620a
IMAGE_SIZE := 32448k
- DEVICE_VENDOR := YOUKU
- DEVICE_MODEL := YK1
+ DEVICE_VENDOR := Youku
+ DEVICE_MODEL := YK-L1
DEVICE_PACKAGES := kmod-usb2 kmod-usb-ohci kmod-sdhci-mt7620 \
kmod-usb-ledtrig-usbport
- SUPPORTED_DEVICES += youku-yk1
+ SUPPORTED_DEVICES += youku-yk1 youku,yk1
endef
-TARGET_DEVICES += youku_yk1
+TARGET_DEVICES += youku_yk-l1
+
+define Device/youku_yk-l1c
+ SOC := mt7620a
+ IMAGE_SIZE := 16064k
+ DEVICE_VENDOR := Youku
+ DEVICE_MODEL := YK-L1c
+ DEVICE_PACKAGES := kmod-usb2 kmod-usb-ohci kmod-sdhci-mt7620 \
+ kmod-usb-ledtrig-usbport
+endef
+TARGET_DEVICES += youku_yk-l1c
define Device/yukai_bocco
SOC := mt7620a
diff --git a/target/linux/ramips/mt7620/base-files/etc/board.d/02_network b/target/linux/ramips/mt7620/base-files/etc/board.d/02_network
index 919102b130..4fd2455f5c 100755
--- a/target/linux/ramips/mt7620/base-files/etc/board.d/02_network
+++ b/target/linux/ramips/mt7620/base-files/etc/board.d/02_network
@@ -216,7 +216,8 @@ ramips_setup_interfaces()
ucidef_add_switch "switch0" \
"0:lan" "4:wan" "6@eth0"
;;
- youku,yk1)
+ youku,yk-l1|\
+ youku,yk-l1c)
ucidef_add_switch "switch0" \
"0:lan" "1:lan" "4:wan" "6@eth0"
;;
@@ -339,7 +340,8 @@ ramips_setup_macs()
lenovo,newifi-y1s|\
ohyeah,oy-0001|\
wavlink,wl-wn530hg4|\
- youku,yk1)
+ youku,yk-l1|\
+ youku,yk-l1c)
wan_mac=$(mtd_get_mac_binary factory 0x2e)
;;
linksys,e1700)