aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorOscar Molnar <oscar@tymscar.com>2022-08-06 16:13:41 +0100
committerHauke Mehrtens <hauke@hauke-m.de>2022-10-05 22:21:18 +0200
commit830b07f08e7dfde0d5c44b6659dfa3d9af44e208 (patch)
tree45f124fe21ae8363480917f7be3f2c89b63681a8
parent084a8a2fafbaecb821cfa71f0e1c9b8464f23a80 (diff)
downloadupstream-830b07f08e7dfde0d5c44b6659dfa3d9af44e208.tar.gz
upstream-830b07f08e7dfde0d5c44b6659dfa3d9af44e208.tar.bz2
upstream-830b07f08e7dfde0d5c44b6659dfa3d9af44e208.zip
build: add support for python3.11 and higher
python3.11 beta is out but fails to run the makefile currently this supports python versions from 3.6 to 3.99 with the python3 binary it also checks specifically for 3.11 as it is the latest version out Signed-off-by: Oscar Molnar <oscar@tymscar.com> (cherry picked from commit a9e8eec221874e5840d659aed3f68850ff1d9982) Signed-off-by: Michal Vasilek <michal.vasilek@nic.cz> [rebase for 21.02]
-rw-r--r--include/prereq-build.mk6
1 files changed, 4 insertions, 2 deletions
diff --git a/include/prereq-build.mk b/include/prereq-build.mk
index 61cd8ae516..b86e2e00b2 100644
--- a/include/prereq-build.mk
+++ b/include/prereq-build.mk
@@ -153,22 +153,24 @@ $(eval $(call SetupHostCommand,perl,Please install Perl 5.x, \
$(eval $(call CleanupPython2))
$(eval $(call SetupHostCommand,python,Please install Python >= 3.5, \
+ python3.11 -V 2>&1 | grep 'Python 3', \
python3.10 -V 2>&1 | grep 'Python 3', \
python3.9 -V 2>&1 | grep 'Python 3', \
python3.8 -V 2>&1 | grep 'Python 3', \
python3.7 -V 2>&1 | grep 'Python 3', \
python3.6 -V 2>&1 | grep 'Python 3', \
python3.5 -V 2>&1 | grep 'Python 3', \
- python3 -V 2>&1 | grep -E 'Python 3\.([5-9]|10)\.?'))
+ python3 -V 2>&1 | grep -E 'Python 3\.([5-9]|[0-9][0-9])\.?'))
$(eval $(call SetupHostCommand,python3,Please install Python >= 3.5, \
+ python3.11 -V 2>&1 | grep 'Python 3', \
python3.10 -V 2>&1 | grep 'Python 3', \
python3.9 -V 2>&1 | grep 'Python 3', \
python3.8 -V 2>&1 | grep 'Python 3', \
python3.7 -V 2>&1 | grep 'Python 3', \
python3.6 -V 2>&1 | grep 'Python 3', \
python3.5 -V 2>&1 | grep 'Python 3', \
- python3 -V 2>&1 | grep -E 'Python 3\.([5-9]|10)\.?'))
+ python3 -V 2>&1 | grep -E 'Python 3\.([5-9]|[0-9][0-9])\.?'))
$(eval $(call TestHostCommand,python3-distutils, \
Please install the Python3 distutils module, \