diff options
author | Jo-Philipp Wich <jow@openwrt.org> | 2015-02-10 15:48:48 +0000 |
---|---|---|
committer | Jo-Philipp Wich <jow@openwrt.org> | 2015-02-10 15:48:48 +0000 |
commit | 2efe776ab082723fe94e91ae7d45e65480bb3faa (patch) | |
tree | dd201df6a2f86fc93b1f7a34039981e5ce1bff48 | |
parent | 572b94308008ea0323cb11df945ad7c2313fc320 (diff) | |
download | upstream-2efe776ab082723fe94e91ae7d45e65480bb3faa.tar.gz upstream-2efe776ab082723fe94e91ae7d45e65480bb3faa.tar.bz2 upstream-2efe776ab082723fe94e91ae7d45e65480bb3faa.zip |
scripts: extend rstrip.sh to remove bad rpaths
Remove all rpath entries which do not point to a location below /lib or
/usr/lib and which do not begin with '$ORIGIN'.
Signed-off-by: Jo-Philipp Wich <jow@openwrt.org>
SVN-Revision: 44377
-rw-r--r-- | rules.mk | 1 | ||||
-rwxr-xr-x | scripts/rstrip.sh | 12 |
2 files changed, 12 insertions, 1 deletions
@@ -269,6 +269,7 @@ else NM="$(TARGET_CROSS)nm" \ STRIP="$(STRIP)" \ STRIP_KMOD="$(SCRIPT_DIR)/strip-kmod.sh" \ + PATCHELF="$(STAGING_DIR_HOST)/bin/patchelf" \ $(SCRIPT_DIR)/rstrip.sh endif diff --git a/scripts/rstrip.sh b/scripts/rstrip.sh index 4665ff5559..4e4232db60 100755 --- a/scripts/rstrip.sh +++ b/scripts/rstrip.sh @@ -25,11 +25,21 @@ find $TARGETS -type f -a -exec file {} \; | \ ( IFS=":" while read F S; do - echo "$SELF: $F:$S" + echo "$SELF: $F: $S" [ "${S}" = "relocatable" ] && { eval "$STRIP_KMOD $F" } || { b=$(stat -c '%a' $F) + [ -z "$PATCHELF" ] || [ -z "$TOPDIR" ] || { + old_rpath="$($PATCHELF --print-rpath $F)"; new_rpath="" + for path in $old_rpath; do + case "$path" in + /lib/[^/]*|/usr/lib/[^/]*|\$ORIGIN/*) new_rpath="${new_rpath:+$new_rpath:}$path" ;; + *) echo "$SELF: $F: removing rpath $path" ;; + esac + done + [ "$new_rpath" = "$old_rpath" ] || $PATCHELF --set-rpath "$new_rpath" $F + } eval "$STRIP $F" a=$(stat -c '%a' $F) [ "$a" = "$b" ] || chmod $b $F |