aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorPaul Spooren <mail@aparcar.org>2021-10-09 23:09:46 -1000
committerPaul Spooren <mail@aparcar.org>2021-10-12 19:19:30 -1000
commitf1f304940b72def82dc22cebd78436505f2d6b9f (patch)
tree1dcdf950a58c691a821989f0e3b5cc1d67a2db30
parente7c5e08db09a0034a1dc5f013af651339743fd40 (diff)
downloadupstream-f1f304940b72def82dc22cebd78436505f2d6b9f.tar.gz
upstream-f1f304940b72def82dc22cebd78436505f2d6b9f.tar.bz2
upstream-f1f304940b72def82dc22cebd78436505f2d6b9f.zip
build: prereq detect Python 3.10 for `python3` binary
While the binary `python3.10` is correctly detected by the build system the default `python3` binary is currently not detected if pointing to a Python 3.10 installation. Fix this by extending the grep regex. Signed-off-by: Paul Spooren <mail@aparcar.org> (cherry picked from commit 56ea2bf2eec431ccd3c566190a444ad63db39b65)
-rw-r--r--include/prereq-build.mk4
1 files changed, 2 insertions, 2 deletions
diff --git a/include/prereq-build.mk b/include/prereq-build.mk
index 8b6413564d..d28432f726 100644
--- a/include/prereq-build.mk
+++ b/include/prereq-build.mk
@@ -159,7 +159,7 @@ $(eval $(call SetupHostCommand,python,Please install Python >= 3.5, \
python3.7 -V 2>&1 | grep 'Python 3', \
python3.6 -V 2>&1 | grep 'Python 3', \
python3.5 -V 2>&1 | grep 'Python 3', \
- python3 -V 2>&1 | grep -E 'Python 3\.[5-9]\.?'))
+ python3 -V 2>&1 | grep -E 'Python 3\.([5-9]|10)\.?'))
$(eval $(call SetupHostCommand,python3,Please install Python >= 3.5, \
python3.10 -V 2>&1 | grep 'Python 3', \
@@ -168,7 +168,7 @@ $(eval $(call SetupHostCommand,python3,Please install Python >= 3.5, \
python3.7 -V 2>&1 | grep 'Python 3', \
python3.6 -V 2>&1 | grep 'Python 3', \
python3.5 -V 2>&1 | grep 'Python 3', \
- python3 -V 2>&1 | grep -E 'Python 3\.[5-9]\.?'))
+ python3 -V 2>&1 | grep -E 'Python 3\.([5-9]|10)\.?'))
$(eval $(call TestHostCommand,python3-distutils, \
Please install the Python3 distutils module, \