aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDavid Adair <djabhead@aol.com>2021-05-14 16:04:27 -0700
committerHauke Mehrtens <hauke@hauke-m.de>2021-05-23 16:10:59 +0200
commita52842a8d05e71ee46eca70c0165518d02674fa2 (patch)
tree58599226035aad9d9e67772d84b7517e8cbf51e8
parent1a2ebb88f521a25964eaf2ee9708474fc5328ac5 (diff)
downloadupstream-a52842a8d05e71ee46eca70c0165518d02674fa2.tar.gz
upstream-a52842a8d05e71ee46eca70c0165518d02674fa2.tar.bz2
upstream-a52842a8d05e71ee46eca70c0165518d02674fa2.zip
ccache: Build with ENABLE_DOCUMENTATION=OFF
This adjusts the Makefile to use the new option to turn off the doc builds. It will not cause any problems except a warning about unused options if combined with a ccache source missing the upstream patch. Since a config setting is required to re-enable the doc build this is equivalent to unconditionally disabling the docs if the config setting is not created. Signed-off-by: David Adair <djabhead@aol.com> (cherry picked from commit 2d1546832357a3a8bd18680bd31dd92050e739b2)
-rw-r--r--tools/ccache/Makefile3
1 files changed, 3 insertions, 0 deletions
diff --git a/tools/ccache/Makefile b/tools/ccache/Makefile
index ff0204ae19..c69e26bd23 100644
--- a/tools/ccache/Makefile
+++ b/tools/ccache/Makefile
@@ -25,6 +25,9 @@ CMAKE_HOST_OPTIONS += \
-DCMAKE_SKIP_RPATH=FALSE \
-DCMAKE_INSTALL_RPATH="${STAGING_DIR_HOST}/lib" \
+ifneq (docs-$(CONFIG_BUILD_DOCUMENTATION),docs-y)
+CMAKE_HOST_OPTIONS += -DENABLE_DOCUMENTATION=OFF
+endif
define Host/Install/ccache
$(INSTALL_DIR) $(STAGING_DIR_HOST)/bin/