aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLech Perczak <lech.perczak@gmail.com>2021-02-28 03:24:19 +0100
committerBaptiste Jonglez <git@bitsofnetworks.org>2021-06-02 21:29:16 +0200
commit6a5545006e2339b179438bddb61ed98b712f1d1b (patch)
tree33297fa1c138ed6e098020bd87eab3de6e4265be
parent27bcde303b0a5a1d77a36463afd776f819f43b82 (diff)
downloadupstream-6a5545006e2339b179438bddb61ed98b712f1d1b.tar.gz
upstream-6a5545006e2339b179438bddb61ed98b712f1d1b.tar.bz2
upstream-6a5545006e2339b179438bddb61ed98b712f1d1b.zip
rampis: use lzma-loader for ZTE MF283+
Without that, after merging support to master, the device fails to boot due to LZMA decompression error: 3: System Boot system code via Flash. raspi_read: from:80000 len:40 . Image Name: MIPS OpenWrt Linux-5.4.99 Created: 2021-02-25 23:35:00 UTC Image Type: MIPS Linux Kernel Image (lzma compressed) Data Size: 1786664 Bytes = 1.7 MB Load Address: 80000000 Entry Point: 80000000 raspi_read: from:80040 len:1b4328 ............................ Verifying Checksum ... OK Uncompressing Kernel Image ... LZMA ERROR 1 - must RESET board to recover Use lzma-loader to fix it. Fixes: 59d065c9f81c ("ramips: add support for ZTE MF283+") Signed-off-by: Lech Perczak <lech.perczak@gmail.com> (cherry picked from commit 410fb05b445c89a147029d1471e184a5594602db) Signed-off-by: Lech Perczak <lech.perczak@gmail.com>
-rw-r--r--target/linux/ramips/image/rt305x.mk1
1 files changed, 1 insertions, 0 deletions
diff --git a/target/linux/ramips/image/rt305x.mk b/target/linux/ramips/image/rt305x.mk
index c16de3049f..5483b8a369 100644
--- a/target/linux/ramips/image/rt305x.mk
+++ b/target/linux/ramips/image/rt305x.mk
@@ -1184,6 +1184,7 @@ endef
TARGET_DEVICES += zorlik_zl5900v2
define Device/zte_mf283plus
+ $(Device/uimage-lzma-loader)
SOC := rt3352
IMAGE_SIZE := 15872k
DEVICE_VENDOR := ZTE