aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Schiller <ms.3headeddevs@gmail.com>2019-08-21 09:06:54 +0200
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2020-07-17 12:14:32 +0200
commit4d8552c26527428e041a490a365b5cbd3495119e (patch)
treeedde8db8bd1431979f33c6a2694b4de20d277470
parent1de9cac2f993738bf6a7ff2261bb382549a7863b (diff)
downloadupstream-4d8552c26527428e041a490a365b5cbd3495119e.tar.gz
upstream-4d8552c26527428e041a490a365b5cbd3495119e.tar.bz2
upstream-4d8552c26527428e041a490a365b5cbd3495119e.zip
lantiq: move dsl related base-files into own package
It does not make sense to install this components on lantiq systems where the dsl subsystem is not needed/used. This also makes it possible to use the files also on other targets. (hopefully ipq401x / FritzBox 7530 in the near future) Signed-off-by: Martin Schiller <ms.3headeddevs@gmail.com>
-rw-r--r--package/network/config/ltq-adsl-app/Makefile2
-rw-r--r--package/network/config/ltq-vdsl-app/Makefile2
-rw-r--r--package/network/utils/ltq-dsl-base/Makefile32
-rwxr-xr-xpackage/network/utils/ltq-dsl-base/files/etc/hotplug.d/dsl/led_dsl.sh (renamed from target/linux/lantiq/base-files/etc/hotplug.d/dsl/led_dsl.sh)0
-rwxr-xr-xpackage/network/utils/ltq-dsl-base/files/etc/hotplug.d/dsl/pppoa.sh (renamed from target/linux/lantiq/base-files/etc/hotplug.d/dsl/pppoa.sh)0
-rwxr-xr-xpackage/network/utils/ltq-dsl-base/files/lib/functions/lantiq_dsl.sh (renamed from target/linux/lantiq/base-files/lib/functions/lantiq_dsl.sh)0
-rwxr-xr-xpackage/network/utils/ltq-dsl-base/files/sbin/dsl_notify.sh (renamed from target/linux/lantiq/base-files/sbin/dsl_notify.sh)0
7 files changed, 34 insertions, 2 deletions
diff --git a/package/network/config/ltq-adsl-app/Makefile b/package/network/config/ltq-adsl-app/Makefile
index 98c22a655f..4317f3d712 100644
--- a/package/network/config/ltq-adsl-app/Makefile
+++ b/package/network/config/ltq-adsl-app/Makefile
@@ -35,7 +35,7 @@ define Package/ltq-adsl-app
CATEGORY:=Network
TITLE:=Lantiq DSL userland tool
URL:=http://www.lantiq.com/
- DEPENDS:=@(TARGET_lantiq_xway||TARGET_lantiq_xway_legacy||TARGET_lantiq_ase) +libpthread
+ DEPENDS:=@(TARGET_lantiq_xway||TARGET_lantiq_xway_legacy||TARGET_lantiq_ase) +libpthread +ltq-dsl-base
MENU:=1
endef
diff --git a/package/network/config/ltq-vdsl-app/Makefile b/package/network/config/ltq-vdsl-app/Makefile
index 670f720e29..92d6faf736 100644
--- a/package/network/config/ltq-vdsl-app/Makefile
+++ b/package/network/config/ltq-vdsl-app/Makefile
@@ -28,7 +28,7 @@ define Package/ltq-vdsl-app
CATEGORY:=Network
TITLE:=Lantiq VDSL userland tool
URL:=http://www.lantiq.com/
- DEPENDS:=@TARGET_lantiq_xrx200 +libpthread +librt
+ DEPENDS:=@TARGET_lantiq_xrx200 +libpthread +librt +ltq-dsl-base
endef
define Package/ltq-vdsl-app/description
diff --git a/package/network/utils/ltq-dsl-base/Makefile b/package/network/utils/ltq-dsl-base/Makefile
new file mode 100644
index 0000000000..6b931f7abd
--- /dev/null
+++ b/package/network/utils/ltq-dsl-base/Makefile
@@ -0,0 +1,32 @@
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=ltq-dsl-base
+PKG_RELEASE:=1
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/ltq-dsl-base
+ SECTION:=net
+ CATEGORY:=Network
+ TITLE:=DSL related files for Intel/Lantiq DSL Chipsets
+ URL:=http://openwrt.org/
+ DEPENDS:=@TARGET_lantiq +jshn
+endef
+
+define Package/ltq-dsl-base/description
+ This package contains DSL related files for Intel/Lantiq DSL Chipsets.
+endef
+
+define Build/Compile
+endef
+
+define Package/ltq-dsl-base/install
+ $(CP) ./files/* $(1)/
+endef
+
+$(eval $(call BuildPackage,ltq-dsl-base))
diff --git a/target/linux/lantiq/base-files/etc/hotplug.d/dsl/led_dsl.sh b/package/network/utils/ltq-dsl-base/files/etc/hotplug.d/dsl/led_dsl.sh
index dd8e84a1af..dd8e84a1af 100755
--- a/target/linux/lantiq/base-files/etc/hotplug.d/dsl/led_dsl.sh
+++ b/package/network/utils/ltq-dsl-base/files/etc/hotplug.d/dsl/led_dsl.sh
diff --git a/target/linux/lantiq/base-files/etc/hotplug.d/dsl/pppoa.sh b/package/network/utils/ltq-dsl-base/files/etc/hotplug.d/dsl/pppoa.sh
index 4506737672..4506737672 100755
--- a/target/linux/lantiq/base-files/etc/hotplug.d/dsl/pppoa.sh
+++ b/package/network/utils/ltq-dsl-base/files/etc/hotplug.d/dsl/pppoa.sh
diff --git a/target/linux/lantiq/base-files/lib/functions/lantiq_dsl.sh b/package/network/utils/ltq-dsl-base/files/lib/functions/lantiq_dsl.sh
index 11b02fc4aa..11b02fc4aa 100755
--- a/target/linux/lantiq/base-files/lib/functions/lantiq_dsl.sh
+++ b/package/network/utils/ltq-dsl-base/files/lib/functions/lantiq_dsl.sh
diff --git a/target/linux/lantiq/base-files/sbin/dsl_notify.sh b/package/network/utils/ltq-dsl-base/files/sbin/dsl_notify.sh
index d615db5f05..d615db5f05 100755
--- a/target/linux/lantiq/base-files/sbin/dsl_notify.sh
+++ b/package/network/utils/ltq-dsl-base/files/sbin/dsl_notify.sh