aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorPhilip Prindeville <philipp@redfish-solutions.com>2021-03-19 15:09:45 -0600
committerHauke Mehrtens <hauke@hauke-m.de>2021-04-10 15:05:18 +0200
commitdc31191ec3e5cefc8eceb5b1525d14e8e81c59ed (patch)
tree96d4a2f553d4ee17c8d7900285463e737425bb30
parentf1158fbcf63c190fb4f7686075ab99f2aee98a92 (diff)
downloadupstream-dc31191ec3e5cefc8eceb5b1525d14e8e81c59ed.tar.gz
upstream-dc31191ec3e5cefc8eceb5b1525d14e8e81c59ed.tar.bz2
upstream-dc31191ec3e5cefc8eceb5b1525d14e8e81c59ed.zip
build: make sure asm gets built with -DPIC
Fixes issue openwrt/packages#14921, whereby inline ASM wasn't getting built as PIC; look at gmp-6.2.1/mpn/x86/pentium/popcount.asm for example: ifdef(`PIC',` ... for a routine that exists in both PIC and non-PIC versions. Make sure that wherever $(FPIC) gets passed as a variable expansion that it gets quoted where necessary (such as setting environment variables in shell commands). Signed-off-by: Philip Prindeville <philipp@redfish-solutions.com> (cherry picked from commit af22991e03cae55f96b06996df2ff16752cec5d5)
-rw-r--r--rules.mk6
1 files changed, 3 insertions, 3 deletions
diff --git a/rules.mk b/rules.mk
index 8f41ff5861..f31d9bb113 100644
--- a/rules.mk
+++ b/rules.mk
@@ -75,12 +75,12 @@ IS_PACKAGE_BUILD := $(if $(filter package/%,$(BUILD_SUBDIR)),1)
OPTIMIZE_FOR_CPU=$(subst i386,i486,$(ARCH))
ifneq (,$(findstring $(ARCH) , aarch64 aarch64_be powerpc ))
- FPIC:=-fPIC
+ FPIC:=-DPIC -fPIC
else
- FPIC:=-fpic
+ FPIC:=-DPIC -fpic
endif
-HOST_FPIC:=-fPIC
+HOST_FPIC:=-DPIC -fPIC
ARCH_SUFFIX:=$(call qstrip,$(CONFIG_CPU_TYPE))
GCC_ARCH:=