aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDonald Hoskins <grommish@gmail.com>2021-02-14 15:35:45 -0500
committerHauke Mehrtens <hauke@hauke-m.de>2021-03-29 22:26:27 +0200
commitb2c9a8741ff2ea4c6689482aece0f35e15b428c8 (patch)
tree4c5502e0d62d16e5591413231a484117de304d63
parentda7ef7f41434f4f49f8f76319f8043135108b9c0 (diff)
downloadupstream-b2c9a8741ff2ea4c6689482aece0f35e15b428c8.tar.gz
upstream-b2c9a8741ff2ea4c6689482aece0f35e15b428c8.tar.bz2
upstream-b2c9a8741ff2ea4c6689482aece0f35e15b428c8.zip
libunwind: Add MIPS64 dep check
libunwind dependency check does not allow for MIPS64 arch. Add MIPS64 awareness. libunwind seems to support MIPS64 without issues, it was limited by the dep arch check in the Makefile. Used to compile Suricata6/Rust locally without issue. Signed-off-by: Donald Hoskins <grommish@gmail.com> (cherry picked from commit ea6d4bdde20a3fecbfc44b99f53373e1d0666e34)
-rw-r--r--package/libs/libunwind/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/libs/libunwind/Makefile b/package/libs/libunwind/Makefile
index 89e6f84ff5..7f79996d25 100644
--- a/package/libs/libunwind/Makefile
+++ b/package/libs/libunwind/Makefile
@@ -32,7 +32,7 @@ define Package/libunwind
CATEGORY:=Libraries
TITLE:=The libunwind project
URL:=http://www.nongnu.org/libunwind/
- DEPENDS:=@((mips||mipsel||x86_64||arm||aarch64)||(USE_GLIBC&&(powerpc||i386))) +zlib
+ DEPENDS:=@((mips||mipsel||mips64||x86_64||arm||aarch64)||(USE_GLIBC&&(powerpc||i386))) +zlib
ABI_VERSION:=8
endef