aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRadek Dostál <rd@radekdostal.com>2018-10-22 22:34:17 +0200
committerKoen Vandeputte <koen.vandeputte@ncentric.com>2018-10-29 11:21:23 +0100
commit9d35b6877687f0ac903bdcec806210cfd2f51488 (patch)
tree055286bbd776fa601214ac1433b2a0d93e2d1b02
parentf89fc43a50998a69bd401268020ab78b90ff7a34 (diff)
downloadupstream-9d35b6877687f0ac903bdcec806210cfd2f51488.tar.gz
upstream-9d35b6877687f0ac903bdcec806210cfd2f51488.tar.bz2
upstream-9d35b6877687f0ac903bdcec806210cfd2f51488.zip
ar71xx: switch TP-Link RE450 v1 to dynamic partitioning
As mentioned in commit 5f24933 recent changes on ar71xx (switch to 4.14, memory compaction, ...) cause an increase in kernel size, making it too big for RE450. RE450 images were not build due to the following error message: os-image partition too big (more than 1572864 bytes): Success Tested on RE450, device boots and was used to send this patch. Reported-by: Enrico Mioso <mrkiko.rs@gmail.com> Suggested-by: David Bauer <mail@david-bauer.net> Signed-off-by: Radek Dostál <rd@radekdostal.com> [rewrote commit msg keeping it tight + fixed SoB lines] Signed-off-by: Koen Vandeputte <koen.vandeputte@ncentric.com>
-rw-r--r--target/linux/ar71xx/image/generic-tp-link.mk2
-rw-r--r--tools/firmware-utils/src/tplink-safeloader.c9
2 files changed, 4 insertions, 7 deletions
diff --git a/target/linux/ar71xx/image/generic-tp-link.mk b/target/linux/ar71xx/image/generic-tp-link.mk
index 39d3ab08fe..5036e85a01 100644
--- a/target/linux/ar71xx/image/generic-tp-link.mk
+++ b/target/linux/ar71xx/image/generic-tp-link.mk
@@ -254,6 +254,8 @@ define Device/re450-v1
DEVICE_PROFILE := RE450
TPLINK_HWID := 0x0
TPLINK_HWREV := 0
+ KERNEL := kernel-bin | patch-cmdline | lzma | tplink-v1-header -O
+ KERNEL_INITRAMFS := kernel-bin | patch-cmdline | lzma | tplink-v1-header
endef
TARGET_DEVICES += re450-v1
diff --git a/tools/firmware-utils/src/tplink-safeloader.c b/tools/firmware-utils/src/tplink-safeloader.c
index 78092bc535..7f8a5d22ad 100644
--- a/tools/firmware-utils/src/tplink-safeloader.c
+++ b/tools/firmware-utils/src/tplink-safeloader.c
@@ -1103,15 +1103,10 @@ static struct device_info boards[] = {
.support_trail = '\x00',
.soft_ver = NULL,
- /**
- The flash partition table for RE450;
- it is almost the same as the one used by the stock images,
- 576KB were moved from file-system to os-image.
- */
+ /** We're using a dynamic kernel/rootfs split here */
.partitions = {
{"fs-uboot", 0x00000, 0x20000},
- {"os-image", 0x20000, 0x180000},
- {"file-system", 0x1a0000, 0x460000},
+ {"firmware", 0x20000, 0x5e0000},
{"partition-table", 0x600000, 0x02000},
{"default-mac", 0x610000, 0x00020},
{"pin", 0x610100, 0x00020},