aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRafał Miłecki <rafal@milecki.pl>2021-04-08 09:12:43 +0200
committerRafał Miłecki <rafal@milecki.pl>2021-04-08 13:16:14 +0200
commit541db110bb90b6c965a71d597a14a48cd79a234a (patch)
tree19984b0d52a4fb20f65519278d3459f41e3bb503
parent91e0865ff576cad261a9cabc6b0e7dc2c7ce7508 (diff)
downloadupstream-541db110bb90b6c965a71d597a14a48cd79a234a.tar.gz
upstream-541db110bb90b6c965a71d597a14a48cd79a234a.tar.bz2
upstream-541db110bb90b6c965a71d597a14a48cd79a234a.zip
bcm4908: enable target & Asus GT-AC5300 image
OpenWrt was succesfully tested on the GT-AC5300 model. It's possible to: 1. Install OpenWrt using vendor UI 2. Perform UBI aware sysupgrade 3. Install vendor firmware using OpenWrt sysupgrade Signed-off-by: Rafał Miłecki <rafal@milecki.pl> (cherry picked from commit 5e78cb9b85a045f436abf6a03aa5c774d30e1090)
-rw-r--r--target/linux/bcm4908/Makefile2
-rw-r--r--target/linux/bcm4908/image/Makefile2
2 files changed, 3 insertions, 1 deletions
diff --git a/target/linux/bcm4908/Makefile b/target/linux/bcm4908/Makefile
index 4edd0ccfa8..ce5f230ca6 100644
--- a/target/linux/bcm4908/Makefile
+++ b/target/linux/bcm4908/Makefile
@@ -5,7 +5,7 @@ include $(TOPDIR)/rules.mk
ARCH:=aarch64
BOARD:=bcm4908
BOARDNAME:=Broadcom BCM4908 (ARMv8A CPUs Brahma-B53)
-FEATURES:=squashfs nand usb pci pcie gpio source-only
+FEATURES:=squashfs nand usb pci pcie gpio
CPU_TYPE:=cortex-a53
SUBTARGETS:=generic
diff --git a/target/linux/bcm4908/image/Makefile b/target/linux/bcm4908/image/Makefile
index 0b4f0c13c1..1c0781f643 100644
--- a/target/linux/bcm4908/image/Makefile
+++ b/target/linux/bcm4908/image/Makefile
@@ -71,6 +71,7 @@ define Device/netgear_r8000p
IMAGE/chk := append-ubi | bcm4908img | netgear-chk
NETGEAR_BOARD_ID := U12H359T00_NETGEAR
NETGEAR_REGION := 1
+ BROKEN := y
endef
TARGET_DEVICES += netgear_r8000p
@@ -81,6 +82,7 @@ define Device/tplink_archer-c2300-v1
DEVICE_DTS := broadcom/bcm4908/bcm4906-tplink-archer-c2300-v1
IMAGES := bin
IMAGE/bin := append-ubi | bcm4908img
+ BROKEN := y
endef
TARGET_DEVICES += tplink_archer-c2300-v1