aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRafał Miłecki <rafal@milecki.pl>2021-04-13 10:15:39 +0200
committerRafał Miłecki <rafal@milecki.pl>2021-04-14 08:42:38 +0200
commit50f2f25d588bef24856cf220a7bbdd58d96ce6fd (patch)
tree40ab2f558c997b6290a7588e1e17cf0108a8f08c
parent48262735d9b7b824e947d8ea0b6b8571f678f265 (diff)
downloadupstream-50f2f25d588bef24856cf220a7bbdd58d96ce6fd.tar.gz
upstream-50f2f25d588bef24856cf220a7bbdd58d96ce6fd.tar.bz2
upstream-50f2f25d588bef24856cf220a7bbdd58d96ce6fd.zip
kernel: limit crypto-hw-ccp to the x86
CRYPTO_DEV_CCP depends on X86 or ARM64 CRYPTO_DEV_CCP_DD depends on CPU_SUP_AMD or ARM64 Compiling this driver makes sense for x86 mainly. If one day support for ARM64 board with AMD Secure Processor gets added this package may be updated. Trying to build this package on bcm4908 was causing: ERROR: module 'build_dir/target-aarch64_cortex-a53_musl/linux-bcm4908_generic/linux-5.4.110/drivers/crypto/ccp/ccp-crypto.ko' is missing. Signed-off-by: Rafał Miłecki <rafal@milecki.pl> (cherry picked from commit cb3fb45ed1262355e8c31d8e522f411169ee6df8)
-rw-r--r--package/kernel/linux/modules/crypto.mk1
1 files changed, 1 insertions, 0 deletions
diff --git a/package/kernel/linux/modules/crypto.mk b/package/kernel/linux/modules/crypto.mk
index b8b9e5f9fd..b50ed06824 100644
--- a/package/kernel/linux/modules/crypto.mk
+++ b/package/kernel/linux/modules/crypto.mk
@@ -314,6 +314,7 @@ $(eval $(call KernelPackage,crypto-hmac))
define KernelPackage/crypto-hw-ccp
TITLE:=AMD Cryptographic Coprocessor
DEPENDS:= \
+ @TARGET_x86 \
+kmod-crypto-authenc \
+kmod-crypto-hash \
+kmod-crypto-manager \