aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2009-04-06 19:00:20 +0000
committerNicolas Thill <nico@openwrt.org>2009-04-06 19:00:20 +0000
commit3b53bd7ef3839be3b0583bd12f64acf9cbc197d5 (patch)
tree8788d5803b818d45f73137a47c866313c20aeb82
parentcdf292ac64b4997bc694188f9ea2339b3dc369fb (diff)
downloadupstream-3b53bd7ef3839be3b0583bd12f64acf9cbc197d5.tar.gz
upstream-3b53bd7ef3839be3b0583bd12f64acf9cbc197d5.tar.bz2
upstream-3b53bd7ef3839be3b0583bd12f64acf9cbc197d5.zip
accomodate netfilter module (xt_recent) name change in 2.6.28, add missing kconfig when xt_recent is enabled
SVN-Revision: 15123
-rw-r--r--include/netfilter.mk1
-rw-r--r--target/linux/generic-2.6/config-2.6.281
2 files changed, 2 insertions, 0 deletions
diff --git a/include/netfilter.mk b/include/netfilter.mk
index 63773722cc..fb1dc334a4 100644
--- a/include/netfilter.mk
+++ b/include/netfilter.mk
@@ -68,6 +68,7 @@ $(eval $(call nf_add,IPT_CONNTRACK_EXTRA,CONFIG_NETFILTER_XT_MATCH_CONNTRACK, $(
$(eval $(call nf_add,IPT_CONNTRACK_EXTRA,CONFIG_IP_NF_MATCH_HELPER, $(P_V4)ipt_helper))
$(eval $(call nf_add,IPT_CONNTRACK_EXTRA,CONFIG_NETFILTER_XT_MATCH_HELPER, $(P_XT)xt_helper))
$(eval $(call nf_add,IPT_CONNTRACK_EXTRA,CONFIG_IP_NF_MATCH_RECENT, $(P_V4)ipt_recent))
+$(eval $(call nf_add,IPT_CONNTRACK_EXTRA,CONFIG_NETFILTER_XT_MATCH_RECENT, $(P_XT)xt_recent))
$(eval $(call nf_add,IPT_CONNTRACK_EXTRA,CONFIG_IP_NF_TARGET_CONNMARK, $(P_V4)ipt_CONNMARK))
$(eval $(call nf_add,IPT_CONNTRACK_EXTRA,CONFIG_NETFILTER_XT_TARGET_CONNMARK, $(P_XT)xt_CONNMARK))
diff --git a/target/linux/generic-2.6/config-2.6.28 b/target/linux/generic-2.6/config-2.6.28
index 262bec2998..82fbb95070 100644
--- a/target/linux/generic-2.6/config-2.6.28
+++ b/target/linux/generic-2.6/config-2.6.28
@@ -975,6 +975,7 @@ CONFIG_NETFILTER_ADVANCED=y
# CONFIG_NETFILTER_XT_MATCH_RATEEST is not set
# CONFIG_NETFILTER_XT_MATCH_REALM is not set
# CONFIG_NETFILTER_XT_MATCH_RECENT is not set
+# CONFIG_NETFILTER_XT_MATCH_RECENT_PROC_COMPAT is not set
# CONFIG_NETFILTER_XT_MATCH_SCTP is not set
# CONFIG_NETFILTER_XT_MATCH_STATE is not set
# CONFIG_NETFILTER_XT_MATCH_STATISTIC is not set