aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSandeep Sheriker M <sandeep.sheriker@microchip.com>2019-08-14 00:42:15 +0000
committerHauke Mehrtens <hauke@hauke-m.de>2019-08-17 23:08:44 +0200
commit0b7c66c93b30ca43094bbb7bfff9b2eee9b63585 (patch)
tree5a4c0cfc9dac103074da73623da0c24174ad81b3
parent8ff5d69734a5ec84e6a1a720390648f576497974 (diff)
downloadupstream-0b7c66c93b30ca43094bbb7bfff9b2eee9b63585.tar.gz
upstream-0b7c66c93b30ca43094bbb7bfff9b2eee9b63585.tar.bz2
upstream-0b7c66c93b30ca43094bbb7bfff9b2eee9b63585.zip
at91bootstrap: add sama5d27_som1_eksd1_uboot as default defconfig
Signed-off-by: Sandeep Sheriker M <sandeep.sheriker@microchip.com>
-rw-r--r--package/boot/at91bootstrap/Makefile6
-rw-r--r--target/linux/at91/image/Makefile10
2 files changed, 10 insertions, 6 deletions
diff --git a/package/boot/at91bootstrap/Makefile b/package/boot/at91bootstrap/Makefile
index 82f9ca8e26..c4edddf848 100644
--- a/package/boot/at91bootstrap/Makefile
+++ b/package/boot/at91bootstrap/Makefile
@@ -128,9 +128,9 @@ AT91BOOTSTRAP_TARGETS := \
sama5d4_xplainednf_uboot_secure \
sama5d4_xplaineddf_uboot_secure \
sama5d4_xplainedsd_uboot_secure \
- sama5d27_som1_eksd_uboot \
- sama5d27_som1_ekqspi_uboot \
- sama5d2_ptc_eknf_uboot \
+ sama5d27_som1_eksd1_uboot \
+ sama5d27_som1_ekqspi_uboot \
+ sama5d2_ptc_eknf_uboot \
sama5d2_ptc_eksd_uboot
define Build/Compile
diff --git a/target/linux/at91/image/Makefile b/target/linux/at91/image/Makefile
index e4c17e3a3c..3a906a6ca8 100644
--- a/target/linux/at91/image/Makefile
+++ b/target/linux/at91/image/Makefile
@@ -55,9 +55,13 @@ define Build/at91-sdcard
$(BIN_DIR)/u-boot-$(DEVICE_NAME:at91-%=%)_mmc/u-boot.bin \
::u-boot.bin
- mcopy -i $@.boot \
- $(BIN_DIR)/at91bootstrap-$(DEVICE_NAME:at91-%=%)sd*/at91bootstrap.bin \
- ::BOOT.bin
+ $(if $(findstring at91-sama5d27_som1_ek,$@), \
+ mcopy -i $@.boot \
+ $(BIN_DIR)/at91bootstrap-$(DEVICE_NAME:at91-%=%)sd1_uboot/at91bootstrap.bin \
+ ::BOOT.bin,
+ mcopy -i $@.boot \
+ $(BIN_DIR)/at91bootstrap-$(DEVICE_NAME:at91-%=%)sd_uboot/at91bootstrap.bin \
+ ::BOOT.bin)
./gen_at91_sdcard_img.sh \
$@.img \