aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2021-04-04 18:32:30 -0700
committerHauke Mehrtens <hauke@hauke-m.de>2021-04-18 12:04:43 +0200
commit09a23b9261f86e6d82c5b3cf55060a7ece997c15 (patch)
treede4a9654e2351679d08399e6a100f9af1e5f08ca
parentd33f4f856566bf7a5b44d6169fd673719bbdfcc6 (diff)
downloadupstream-09a23b9261f86e6d82c5b3cf55060a7ece997c15.tar.gz
upstream-09a23b9261f86e6d82c5b3cf55060a7ece997c15.tar.bz2
upstream-09a23b9261f86e6d82c5b3cf55060a7ece997c15.zip
toolchain/gdb: fix compilation with ccache
For some reason, one of the configure checks results in some infinite loop and ends up spawning endless gcc processes, causing OOM. Just pass a configure var to avoid it. Same fix as 6e23813c1ed7494a9da3b5e59cfcafd71097c420 Signed-off-by: Rosen Penev <rosenp@gmail.com> (cherry picked from commit fc093c3f9cce80ea60e3752f6629f999ec186765)
-rw-r--r--toolchain/gdb/Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/toolchain/gdb/Makefile b/toolchain/gdb/Makefile
index 3bcc9d1238..05e3c7de3c 100644
--- a/toolchain/gdb/Makefile
+++ b/toolchain/gdb/Makefile
@@ -22,6 +22,7 @@ HOST_BUILD_PARALLEL:=1
include $(INCLUDE_DIR)/toolchain-build.mk
HOST_CONFIGURE_VARS += \
+ acx_cv_cc_gcc_supports_ada=false \
gdb_cv_func_sigsetjmp=yes
HOST_CONFIGURE_ARGS = \