aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorStijn Tintel <stijn@linux-ipv6.be>2021-08-18 16:11:11 +0300
committerDavid Bauer <mail@david-bauer.net>2021-08-24 19:41:47 +0200
commit662401d903ae542e9868e572e318d5411ec756a7 (patch)
treedfb04a46420810c8d0002bf98b15c46ed912a485
parent61c65acbda9720f445f1c696a871d1c79578cbdf (diff)
downloadupstream-662401d903ae542e9868e572e318d5411ec756a7.tar.gz
upstream-662401d903ae542e9868e572e318d5411ec756a7.tar.bz2
upstream-662401d903ae542e9868e572e318d5411ec756a7.zip
ipq40xx: fix Edgecore ECW5211 boot
The bootloader will look for a configuration section named ap.dk01.1-c2 in the FIT image. If this doesn't exist, the device won't boot. Signed-off-by: Stijn Tintel <stijn@linux-ipv6.be> (cherry picked from commit a43da1be43ae251f0edaa6419612e600fc6ec972)
-rw-r--r--target/linux/ipq40xx/image/generic.mk1
1 files changed, 1 insertions, 0 deletions
diff --git a/target/linux/ipq40xx/image/generic.mk b/target/linux/ipq40xx/image/generic.mk
index 358a583f84..a435a127fa 100644
--- a/target/linux/ipq40xx/image/generic.mk
+++ b/target/linux/ipq40xx/image/generic.mk
@@ -355,6 +355,7 @@ define Device/edgecore_ecw5211
SOC := qcom-ipq4018
BLOCKSIZE := 128k
PAGESIZE := 2048
+ DEVICE_DTS_CONFIG := config@ap.dk01.1-c2
DEVICE_PACKAGES := kmod-tpm-i2c-atmel kmod-usb-acm
endef
TARGET_DEVICES += edgecore_ecw5211