aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndre Heider <a.heider@gmail.com>2021-08-10 12:22:17 +0200
committerHauke Mehrtens <hauke@hauke-m.de>2021-08-28 15:48:08 +0200
commit5bfb9c30a1a3199596dcf07cf64dea7df92a7237 (patch)
tree4d885252878ff930cb307f289f667fe607aacee6
parentf78017006b6ad1f91d411eb003870bfc33a895e0 (diff)
downloadupstream-5bfb9c30a1a3199596dcf07cf64dea7df92a7237.tar.gz
upstream-5bfb9c30a1a3199596dcf07cf64dea7df92a7237.tar.bz2
upstream-5bfb9c30a1a3199596dcf07cf64dea7df92a7237.zip
prereq-build: require python3-distutils
Debian and Ubuntu ship a python3-minimal package which does not include the distutils module. This is not supported by upstream and can be considered a broken python distribution. In practice, many scripts depend on said module, and this is a reoccuring pain point for building various OpenWrt packages. Require and check for said module, enough time has been wasted on this. A list of just the most recent issues: https://github.com/openwrt/packages/pull/16304 https://github.com/openwrt/packages/pull/16027 https://github.com/openwrt/packages/pull/15443 https://github.com/openwrt/packages/pull/14394 https://github.com/openwrt/packages/pull/12909 https://github.com/openwrt/packages/issues/12443 https://github.com/openwrt/packages/pull/11035 https://github.com/openwrt/packages/issues/10993 Signed-off-by: Andre Heider <a.heider@gmail.com> (cherry picked from commit 60af8d753343691c4a647bfc7c51ef6eb92df9f2)
-rw-r--r--include/prereq-build.mk4
1 files changed, 4 insertions, 0 deletions
diff --git a/include/prereq-build.mk b/include/prereq-build.mk
index cb3dcc51e3..538aee58fe 100644
--- a/include/prereq-build.mk
+++ b/include/prereq-build.mk
@@ -168,6 +168,10 @@ $(eval $(call SetupHostCommand,python3,Please install Python >= 3.5, \
python3.5 -V 2>&1 | grep 'Python 3', \
python3 -V 2>&1 | grep -E 'Python 3\.[5-9]\.?'))
+$(eval $(call TestHostCommand,python3-distutils, \
+ Please install the Python3 distutils module, \
+ $(STAGING_DIR_HOST)/bin/python3 -c 'import distutils'))
+
$(eval $(call SetupHostCommand,git,Please install Git (git-core) >= 1.7.12.2, \
git --exec-path | xargs -I % -- grep -q -- --recursive %/git-submodule))