aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAdrian Schmutzler <freifunk@adrianschmutzler.de>2021-03-01 22:28:13 +0100
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2021-03-01 22:33:20 +0100
commita5672f6b96f393145070ad17c8eb1d15ef49ad2e (patch)
tree5960a6a790c414d1dbc04a5766145e2eb6351fa5
parentb4a4d04b919b4a18a03e52a9e6bc18ddd924f554 (diff)
downloadupstream-a5672f6b96f393145070ad17c8eb1d15ef49ad2e.tar.gz
upstream-a5672f6b96f393145070ad17c8eb1d15ef49ad2e.tar.bz2
upstream-a5672f6b96f393145070ad17c8eb1d15ef49ad2e.zip
Revert "base-files: source functions.sh in /lib/functions/system.sh"
This reverts commit 86aeac4fc98f42ac0ce7e0dcf1cb240e16b28f8f. The reverted commit introduced a cyclic dependency between /lib/functions.sh and /lib/functions/system.sh. Further details are found in 282e8173509a ("base-files: do not source system.sh in functions.sh"), which was applied to master some time ago and is included in 21.02. With the current age of 19.07 branch, it seems safer to revert this mostly cosmetic feature than investing further time into disentangling the dependencies. Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
-rw-r--r--package/base-files/Makefile2
-rw-r--r--package/base-files/files/lib/functions/system.sh2
2 files changed, 1 insertions, 3 deletions
diff --git a/package/base-files/Makefile b/package/base-files/Makefile
index 9df5b860f8..dfb84d10d6 100644
--- a/package/base-files/Makefile
+++ b/package/base-files/Makefile
@@ -12,7 +12,7 @@ include $(INCLUDE_DIR)/version.mk
include $(INCLUDE_DIR)/feeds.mk
PKG_NAME:=base-files
-PKG_RELEASE:=204.3
+PKG_RELEASE:=204.4
PKG_FLAGS:=nonshared
PKG_FILE_DEPENDS:=$(PLATFORM_DIR)/ $(GENERIC_PLATFORM_DIR)/base-files/
diff --git a/package/base-files/files/lib/functions/system.sh b/package/base-files/files/lib/functions/system.sh
index e97d00c144..dceb66a851 100644
--- a/package/base-files/files/lib/functions/system.sh
+++ b/package/base-files/files/lib/functions/system.sh
@@ -1,7 +1,5 @@
# Copyright (C) 2006-2013 OpenWrt.org
-. /lib/functions.sh
-
get_mac_binary() {
local path="$1"
local offset="$2"