aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2006-10-04 20:03:26 +0000
committerFelix Fietkau <nbd@openwrt.org>2006-10-04 20:03:26 +0000
commit1bb321cbecc7f046bf8488a7dcf40b016714fe77 (patch)
tree5e306635156889621338913780ed2de3384071e3
parentc9c2d299d6f4912c9e92f0b65c607646c97f5ab7 (diff)
downloadupstream-1bb321cbecc7f046bf8488a7dcf40b016714fe77.tar.gz
upstream-1bb321cbecc7f046bf8488a7dcf40b016714fe77.tar.bz2
upstream-1bb321cbecc7f046bf8488a7dcf40b016714fe77.zip
move arch specific base-files install call to the end of the generic one - fixes wrong /etc/config/network
SVN-Revision: 4914
-rw-r--r--openwrt/package/base-files/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/openwrt/package/base-files/Makefile b/openwrt/package/base-files/Makefile
index 1e234c65a3..9f6da3bc7c 100644
--- a/openwrt/package/base-files/Makefile
+++ b/openwrt/package/base-files/Makefile
@@ -142,7 +142,6 @@ define Package/base-files$(TARGET)/install-brcm
endef
define Package/base-files$(TARGET)/install
- $(call Package/base-files$(TARGET)/install-$(BOARD),$(1))
$(CP) ./default/* $(1)/
if [ -d $(BOARD)-$(KERNEL) ]; then \
$(CP) $(BOARD)-$(KERNEL)/* $(1)/; \
@@ -164,6 +163,7 @@ define Package/base-files$(TARGET)/install
rm -f $(1)/var
ln -sf /tmp $(1)/var
mkdir -p $(1)/etc
+$(call Package/base-files$(TARGET)/install-$(BOARD),$(1))
endef
define Package/libgcc/install