aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2006-10-09 18:17:53 +0000
committerFelix Fietkau <nbd@openwrt.org>2006-10-09 18:17:53 +0000
commit05cdabed622a0a9253325ad170719f88935a2d5e (patch)
tree34eab208420d193a4052effff040703407a0a7df
parentd8c27b90f30073936e0f6ee532027ec86bec31bb (diff)
downloadupstream-05cdabed622a0a9253325ad170719f88935a2d5e.tar.gz
upstream-05cdabed622a0a9253325ad170719f88935a2d5e.tar.bz2
upstream-05cdabed622a0a9253325ad170719f88935a2d5e.zip
move ccache dir to staging_dir_arch (removing the staging dir will make the ccache ineffective anyway)
SVN-Revision: 4999
-rw-r--r--openwrt/Makefile2
-rw-r--r--openwrt/rules.mk2
2 files changed, 2 insertions, 2 deletions
diff --git a/openwrt/Makefile b/openwrt/Makefile
index 89ca7d38b6..ed1e34db47 100644
--- a/openwrt/Makefile
+++ b/openwrt/Makefile
@@ -132,7 +132,7 @@ dirclean: clean
rm -rf staging_dir_* toolchain_build_* tool_build
distclean: dirclean config-clean
- rm -rf dl .*config* .pkg* .prereq ccache_*
+ rm -rf dl .*config* .pkg* .prereq
.SILENT: clean dirclean distclean config-clean download world
FORCE: ;
diff --git a/openwrt/rules.mk b/openwrt/rules.mk
index eebc758224..0ec5daf086 100644
--- a/openwrt/rules.mk
+++ b/openwrt/rules.mk
@@ -60,7 +60,7 @@ CP:=cp -fpR
ifneq ($(CONFIG_CCACHE),)
# FIXME: move this variable to a better location
- export CCACHE_DIR=$(TOPDIR)/ccache_$(ARCH)
+ export CCACHE_DIR=$(STAGING_DIR)/ccache
TARGET_CC:= ccache $(TARGET_CC)
endif