aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKlaus Kudielka <klaus.kudielka@gmail.com>2019-12-27 19:15:31 +0100
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2020-12-04 17:57:25 +0100
commitf61e053e72035dbd90795e794aa9d9ca0ce4e5d1 (patch)
tree061688afa962eb319e92d7495c2a85af90d21824
parentf1525e785e9359bfc34b1362ccf37aca48968028 (diff)
downloadupstream-f61e053e72035dbd90795e794aa9d9ca0ce4e5d1.tar.gz
upstream-f61e053e72035dbd90795e794aa9d9ca0ce4e5d1.tar.bz2
upstream-f61e053e72035dbd90795e794aa9d9ca0ce4e5d1.zip
uboot-envtools: mvebu: update uci defaults for Turris Omnia
On the Turris Omnia 2019, u-boot environment is located at 0xF0000, instead of 0xC0000. The switch happened with u-boot-omnia package version 2019-04-2 (May 10, 2019). Check the installed u-boot release, and set the default accordingly. Signed-off-by: Klaus Kudielka <klaus.kudielka@gmail.com> [bump PKG_RELEASE, use lower case for hex offset] Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de> (cherry picked from commit 04d3b517dc3301e0148a2ce811ffc136568b04bd)
-rw-r--r--package/boot/uboot-envtools/Makefile2
-rw-r--r--package/boot/uboot-envtools/files/mvebu6
2 files changed, 6 insertions, 2 deletions
diff --git a/package/boot/uboot-envtools/Makefile b/package/boot/uboot-envtools/Makefile
index 15579e966b..67d281d30c 100644
--- a/package/boot/uboot-envtools/Makefile
+++ b/package/boot/uboot-envtools/Makefile
@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=uboot-envtools
PKG_DISTNAME:=u-boot
PKG_VERSION:=2018.03
-PKG_RELEASE:=3
+PKG_RELEASE:=3.1
PKG_SOURCE_PROTO:=git
PKG_SOURCE:=$(PKG_DISTNAME)-$(PKG_VERSION).tar.xz
diff --git a/package/boot/uboot-envtools/files/mvebu b/package/boot/uboot-envtools/files/mvebu
index 5af81b0fe1..03c8b393d6 100644
--- a/package/boot/uboot-envtools/files/mvebu
+++ b/package/boot/uboot-envtools/files/mvebu
@@ -15,7 +15,11 @@ board=$(board_name)
case "$board" in
cznic,turris-omnia)
- ubootenv_add_uci_config "/dev/mtd0" "0xC0000" "0x10000" "0x40000"
+ if grep -q 'U-Boot 2015.10-rc2' /dev/mtd0; then
+ ubootenv_add_uci_config "/dev/mtd0" "0xc0000" "0x10000" "0x40000"
+ else
+ ubootenv_add_uci_config "/dev/mtd0" "0xf0000" "0x10000" "0x10000"
+ fi
;;
globalscale,espressobin|\
globalscale,espressobin-emmc|\