aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKoen Vandeputte <koen.vandeputte@ncentric.com>2020-10-07 16:53:22 +0200
committerKoen Vandeputte <koen.vandeputte@ncentric.com>2020-10-12 09:45:54 +0200
commit9c718b5478ac5df8ca4f27dbb70a6201c385aada (patch)
treee73b499786367a1f7b65a20cea640a09ac8e678f
parentb21bea7b1b92abefad53bcfe509b7e44dd488c79 (diff)
downloadupstream-9c718b5478ac5df8ca4f27dbb70a6201c385aada.tar.gz
upstream-9c718b5478ac5df8ca4f27dbb70a6201c385aada.tar.bz2
upstream-9c718b5478ac5df8ca4f27dbb70a6201c385aada.zip
kernel: bump 4.14 to 4.14.200
Refreshed all patches. Compile-tested on: ar71xx, cns3xxx, imx6, x86_64 Runtime-tested on: ar71xx, cns3xxx, imx6 Signed-off-by: Koen Vandeputte <koen.vandeputte@ncentric.com>
-rw-r--r--include/kernel-version.mk4
-rw-r--r--target/linux/ar71xx/patches-4.14/403-mtd_fix_cfi_cmdset_0002_status_check.patch14
-rw-r--r--target/linux/ar71xx/patches-4.14/411-mtd-cfi_cmdset_0002-force-word-write.patch6
-rw-r--r--target/linux/ar71xx/patches-4.14/910-unaligned_access_hacks.patch2
-rw-r--r--target/linux/ath79/patches-4.14/403-mtd_fix_cfi_cmdset_0002_status_check.patch14
-rw-r--r--target/linux/ath79/patches-4.14/910-unaligned_access_hacks.patch2
-rw-r--r--target/linux/brcm2708/patches-4.14/950-0202-drm-vc4-Fix-crash-if-we-have-to-unbind-HDMI.patch4
-rw-r--r--target/linux/generic/backport-4.14/273-batman-adv-Convert-packet.h-to-uapi-header.patch4
-rw-r--r--target/linux/generic/hack-4.14/702-phy_add_aneg_done_function.patch2
-rw-r--r--target/linux/generic/hack-4.14/721-phy_packets.patch4
-rw-r--r--target/linux/generic/hack-4.14/902-debloat_proc.patch2
-rw-r--r--target/linux/generic/pending-4.14/460-mtd-cfi_cmdset_0002-no-erase_suspend.patch2
-rw-r--r--target/linux/generic/pending-4.14/461-mtd-cfi_cmdset_0002-add-buffer-write-cmd-timeout.patch2
-rw-r--r--target/linux/generic/pending-4.14/655-increase_skb_pad.patch2
-rw-r--r--target/linux/generic/pending-4.14/834-ledtrig-libata.patch10
-rw-r--r--target/linux/layerscape/patches-4.14/202-core-linux-support-layerscape.patch2
-rw-r--r--target/linux/layerscape/patches-4.14/819-sdhc-support-layerscape.patch2
-rw-r--r--target/linux/mediatek/patches-4.14/0052-net-phy-add-FC.patch2
-rw-r--r--target/linux/oxnas/patches-4.14/999-libata-hacks.patch10
-rw-r--r--target/linux/ramips/patches-4.14/0037-mtd-cfi-cmdset-0002-force-word-write.patch6
20 files changed, 48 insertions, 48 deletions
diff --git a/include/kernel-version.mk b/include/kernel-version.mk
index 3ffcb3c59c..d894d865a8 100644
--- a/include/kernel-version.mk
+++ b/include/kernel-version.mk
@@ -6,9 +6,9 @@ ifdef CONFIG_TESTING_KERNEL
KERNEL_PATCHVER:=$(KERNEL_TESTING_PATCHVER)
endif
-LINUX_VERSION-4.14 = .199
+LINUX_VERSION-4.14 = .200
-LINUX_KERNEL_HASH-4.14.199 = 02f3432a262b3804745501f8c3c51d735133af48a39909df8b031d0b9653d4f9
+LINUX_KERNEL_HASH-4.14.200 = 5d404a0224a34b5379f1871cc46825487d557c2660459d2b5c3cd4871d699a38
remove_uri_prefix=$(subst git://,,$(subst http://,,$(subst https://,,$(1))))
sanitize_uri=$(call qstrip,$(subst @,_,$(subst :,_,$(subst .,_,$(subst -,_,$(subst /,_,$(1)))))))
diff --git a/target/linux/ar71xx/patches-4.14/403-mtd_fix_cfi_cmdset_0002_status_check.patch b/target/linux/ar71xx/patches-4.14/403-mtd_fix_cfi_cmdset_0002_status_check.patch
index faf4391a57..1a295fa11d 100644
--- a/target/linux/ar71xx/patches-4.14/403-mtd_fix_cfi_cmdset_0002_status_check.patch
+++ b/target/linux/ar71xx/patches-4.14/403-mtd_fix_cfi_cmdset_0002_status_check.patch
@@ -1,6 +1,6 @@
--- a/drivers/mtd/chips/cfi_cmdset_0002.c
+++ b/drivers/mtd/chips/cfi_cmdset_0002.c
-@@ -1641,7 +1641,7 @@ static int __xipram do_write_oneword(str
+@@ -1640,7 +1640,7 @@ static int __xipram do_write_oneword(str
}
if (chip_good(map, adr, datum))
@@ -9,7 +9,7 @@
/* Latency issues. Drop the lock, wait a while and retry */
UDELAY(map, chip, adr, 1);
-@@ -1658,6 +1658,8 @@ static int __xipram do_write_oneword(str
+@@ -1657,6 +1657,8 @@ static int __xipram do_write_oneword(str
goto retry;
}
}
@@ -18,7 +18,7 @@
xip_enable(map, chip, adr);
op_done:
if (mode == FL_OTP_WRITE)
-@@ -2240,7 +2242,6 @@ static int cfi_amdstd_panic_write(struct
+@@ -2239,7 +2241,6 @@ static int cfi_amdstd_panic_write(struct
return 0;
}
@@ -26,7 +26,7 @@
/*
* Handle devices with one erase region, that only implement
* the chip erase command.
-@@ -2308,7 +2309,7 @@ static int __xipram do_erase_chip(struct
+@@ -2307,7 +2308,7 @@ static int __xipram do_erase_chip(struct
}
if (chip_good(map, adr, map_word_ff(map)))
@@ -35,7 +35,7 @@
if (time_after(jiffies, timeo)) {
printk(KERN_WARNING "MTD %s(): software timeout\n",
-@@ -2332,6 +2333,7 @@ static int __xipram do_erase_chip(struct
+@@ -2331,6 +2332,7 @@ static int __xipram do_erase_chip(struct
}
}
@@ -43,7 +43,7 @@
chip->state = FL_READY;
xip_enable(map, chip, adr);
DISABLE_VPP(map);
-@@ -2405,7 +2407,7 @@ static int __xipram do_erase_oneblock(st
+@@ -2404,7 +2406,7 @@ static int __xipram do_erase_oneblock(st
if (chip_good(map, adr, map_word_ff(map))) {
xip_enable(map, chip, adr);
@@ -52,7 +52,7 @@
}
if (time_after(jiffies, timeo)) {
-@@ -2431,6 +2433,7 @@ static int __xipram do_erase_oneblock(st
+@@ -2430,6 +2432,7 @@ static int __xipram do_erase_oneblock(st
}
}
diff --git a/target/linux/ar71xx/patches-4.14/411-mtd-cfi_cmdset_0002-force-word-write.patch b/target/linux/ar71xx/patches-4.14/411-mtd-cfi_cmdset_0002-force-word-write.patch
index 9a367c2ab0..0f7c4d68ed 100644
--- a/target/linux/ar71xx/patches-4.14/411-mtd-cfi_cmdset_0002-force-word-write.patch
+++ b/target/linux/ar71xx/patches-4.14/411-mtd-cfi_cmdset_0002-force-word-write.patch
@@ -35,7 +35,7 @@
/* Atmel chips don't use the same PRI format as AMD chips */
static void fixup_convert_atmel_pri(struct mtd_info *mtd)
-@@ -1800,6 +1804,7 @@ static int cfi_amdstd_write_words(struct
+@@ -1799,6 +1803,7 @@ static int cfi_amdstd_write_words(struct
/*
* FIXME: interleaved mode not tested, and probably not supported!
*/
@@ -43,7 +43,7 @@
static int __xipram do_write_buffer(struct map_info *map, struct flchip *chip,
unsigned long adr, const u_char *buf,
int len)
-@@ -1932,7 +1937,6 @@ static int __xipram do_write_buffer(stru
+@@ -1931,7 +1936,6 @@ static int __xipram do_write_buffer(stru
return ret;
}
@@ -51,7 +51,7 @@
static int cfi_amdstd_write_buffers(struct mtd_info *mtd, loff_t to, size_t len,
size_t *retlen, const u_char *buf)
{
-@@ -2007,6 +2011,7 @@ static int cfi_amdstd_write_buffers(stru
+@@ -2006,6 +2010,7 @@ static int cfi_amdstd_write_buffers(stru
return 0;
}
diff --git a/target/linux/ar71xx/patches-4.14/910-unaligned_access_hacks.patch b/target/linux/ar71xx/patches-4.14/910-unaligned_access_hacks.patch
index c5e201b371..1e9ec3d628 100644
--- a/target/linux/ar71xx/patches-4.14/910-unaligned_access_hacks.patch
+++ b/target/linux/ar71xx/patches-4.14/910-unaligned_access_hacks.patch
@@ -325,7 +325,7 @@
for (p = *head; p; p = p->next) {
--- a/net/ipv4/route.c
+++ b/net/ipv4/route.c
-@@ -464,7 +464,7 @@ static struct neighbour *ipv4_neigh_look
+@@ -465,7 +465,7 @@ static struct neighbour *ipv4_neigh_look
else if (skb)
pkey = &ip_hdr(skb)->daddr;
diff --git a/target/linux/ath79/patches-4.14/403-mtd_fix_cfi_cmdset_0002_status_check.patch b/target/linux/ath79/patches-4.14/403-mtd_fix_cfi_cmdset_0002_status_check.patch
index faf4391a57..1a295fa11d 100644
--- a/target/linux/ath79/patches-4.14/403-mtd_fix_cfi_cmdset_0002_status_check.patch
+++ b/target/linux/ath79/patches-4.14/403-mtd_fix_cfi_cmdset_0002_status_check.patch
@@ -1,6 +1,6 @@
--- a/drivers/mtd/chips/cfi_cmdset_0002.c
+++ b/drivers/mtd/chips/cfi_cmdset_0002.c
-@@ -1641,7 +1641,7 @@ static int __xipram do_write_oneword(str
+@@ -1640,7 +1640,7 @@ static int __xipram do_write_oneword(str
}
if (chip_good(map, adr, datum))
@@ -9,7 +9,7 @@
/* Latency issues. Drop the lock, wait a while and retry */
UDELAY(map, chip, adr, 1);
-@@ -1658,6 +1658,8 @@ static int __xipram do_write_oneword(str
+@@ -1657,6 +1657,8 @@ static int __xipram do_write_oneword(str
goto retry;
}
}
@@ -18,7 +18,7 @@
xip_enable(map, chip, adr);
op_done:
if (mode == FL_OTP_WRITE)
-@@ -2240,7 +2242,6 @@ static int cfi_amdstd_panic_write(struct
+@@ -2239,7 +2241,6 @@ static int cfi_amdstd_panic_write(struct
return 0;
}
@@ -26,7 +26,7 @@
/*
* Handle devices with one erase region, that only implement
* the chip erase command.
-@@ -2308,7 +2309,7 @@ static int __xipram do_erase_chip(struct
+@@ -2307,7 +2308,7 @@ static int __xipram do_erase_chip(struct
}
if (chip_good(map, adr, map_word_ff(map)))
@@ -35,7 +35,7 @@
if (time_after(jiffies, timeo)) {
printk(KERN_WARNING "MTD %s(): software timeout\n",
-@@ -2332,6 +2333,7 @@ static int __xipram do_erase_chip(struct
+@@ -2331,6 +2332,7 @@ static int __xipram do_erase_chip(struct
}
}
@@ -43,7 +43,7 @@
chip->state = FL_READY;
xip_enable(map, chip, adr);
DISABLE_VPP(map);
-@@ -2405,7 +2407,7 @@ static int __xipram do_erase_oneblock(st
+@@ -2404,7 +2406,7 @@ static int __xipram do_erase_oneblock(st
if (chip_good(map, adr, map_word_ff(map))) {
xip_enable(map, chip, adr);
@@ -52,7 +52,7 @@
}
if (time_after(jiffies, timeo)) {
-@@ -2431,6 +2433,7 @@ static int __xipram do_erase_oneblock(st
+@@ -2430,6 +2432,7 @@ static int __xipram do_erase_oneblock(st
}
}
diff --git a/target/linux/ath79/patches-4.14/910-unaligned_access_hacks.patch b/target/linux/ath79/patches-4.14/910-unaligned_access_hacks.patch
index f3332ba5c2..d9cefe1dfa 100644
--- a/target/linux/ath79/patches-4.14/910-unaligned_access_hacks.patch
+++ b/target/linux/ath79/patches-4.14/910-unaligned_access_hacks.patch
@@ -316,7 +316,7 @@
for (p = *head; p; p = p->next) {
--- a/net/ipv4/route.c
+++ b/net/ipv4/route.c
-@@ -464,7 +464,7 @@ static struct neighbour *ipv4_neigh_look
+@@ -465,7 +465,7 @@ static struct neighbour *ipv4_neigh_look
else if (skb)
pkey = &ip_hdr(skb)->daddr;
diff --git a/target/linux/brcm2708/patches-4.14/950-0202-drm-vc4-Fix-crash-if-we-have-to-unbind-HDMI.patch b/target/linux/brcm2708/patches-4.14/950-0202-drm-vc4-Fix-crash-if-we-have-to-unbind-HDMI.patch
index fa4f93216c..cb35f11f5e 100644
--- a/target/linux/brcm2708/patches-4.14/950-0202-drm-vc4-Fix-crash-if-we-have-to-unbind-HDMI.patch
+++ b/target/linux/brcm2708/patches-4.14/950-0202-drm-vc4-Fix-crash-if-we-have-to-unbind-HDMI.patch
@@ -13,7 +13,7 @@ Signed-off-by: Eric Anholt <eric@anholt.net>
--- a/drivers/gpu/drm/vc4/vc4_hdmi.c
+++ b/drivers/gpu/drm/vc4/vc4_hdmi.c
-@@ -1130,7 +1130,7 @@ static int vc4_hdmi_audio_init(struct vc
+@@ -1131,7 +1131,7 @@ static int vc4_hdmi_audio_init(struct vc
* snd_soc_card_get_drvdata() if needed.
*/
snd_soc_card_set_drvdata(card, hdmi);
@@ -22,7 +22,7 @@ Signed-off-by: Eric Anholt <eric@anholt.net>
if (ret) {
dev_err(dev, "Could not register sound card: %d\n", ret);
goto unregister_codec;
-@@ -1147,13 +1147,16 @@ unregister_codec:
+@@ -1148,13 +1148,16 @@ unregister_codec:
static void vc4_hdmi_audio_cleanup(struct vc4_hdmi *hdmi)
{
struct device *dev = &hdmi->pdev->dev;
diff --git a/target/linux/generic/backport-4.14/273-batman-adv-Convert-packet.h-to-uapi-header.patch b/target/linux/generic/backport-4.14/273-batman-adv-Convert-packet.h-to-uapi-header.patch
index a9f744fd13..6d5e4e7c6e 100644
--- a/target/linux/generic/backport-4.14/273-batman-adv-Convert-packet.h-to-uapi-header.patch
+++ b/target/linux/generic/backport-4.14/273-batman-adv-Convert-packet.h-to-uapi-header.patch
@@ -97,7 +97,7 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
#include "translation-table.h"
--- a/net/batman-adv/bridge_loop_avoidance.c
+++ b/net/batman-adv/bridge_loop_avoidance.c
-@@ -49,6 +49,7 @@
+@@ -50,6 +50,7 @@
#include <net/genetlink.h>
#include <net/netlink.h>
#include <net/sock.h>
@@ -105,7 +105,7 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
#include <uapi/linux/batman_adv.h>
#include "hard-interface.h"
-@@ -56,7 +57,6 @@
+@@ -57,7 +58,6 @@
#include "log.h"
#include "netlink.h"
#include "originator.h"
diff --git a/target/linux/generic/hack-4.14/702-phy_add_aneg_done_function.patch b/target/linux/generic/hack-4.14/702-phy_add_aneg_done_function.patch
index 5885c8fae6..c45183a104 100644
--- a/target/linux/generic/hack-4.14/702-phy_add_aneg_done_function.patch
+++ b/target/linux/generic/hack-4.14/702-phy_add_aneg_done_function.patch
@@ -15,7 +15,7 @@
--- a/drivers/net/phy/phy_device.c
+++ b/drivers/net/phy/phy_device.c
-@@ -1466,6 +1466,9 @@ int genphy_update_link(struct phy_device
+@@ -1467,6 +1467,9 @@ int genphy_update_link(struct phy_device
{
int status;
diff --git a/target/linux/generic/hack-4.14/721-phy_packets.patch b/target/linux/generic/hack-4.14/721-phy_packets.patch
index e6e06554de..93d63534eb 100644
--- a/target/linux/generic/hack-4.14/721-phy_packets.patch
+++ b/target/linux/generic/hack-4.14/721-phy_packets.patch
@@ -56,7 +56,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
*/
--- a/include/linux/skbuff.h
+++ b/include/linux/skbuff.h
-@@ -2532,6 +2532,10 @@ static inline int pskb_trim(struct sk_bu
+@@ -2544,6 +2544,10 @@ static inline int pskb_trim(struct sk_bu
return (len < skb->len) ? __pskb_trim(skb, len) : 0;
}
@@ -67,7 +67,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
/**
* pskb_trim_unique - remove end from a paged unique (not cloned) buffer
* @skb: buffer to alter
-@@ -2663,16 +2667,6 @@ static inline struct sk_buff *dev_alloc_
+@@ -2675,16 +2679,6 @@ static inline struct sk_buff *dev_alloc_
}
diff --git a/target/linux/generic/hack-4.14/902-debloat_proc.patch b/target/linux/generic/hack-4.14/902-debloat_proc.patch
index e0c043f78f..222533c42b 100644
--- a/target/linux/generic/hack-4.14/902-debloat_proc.patch
+++ b/target/linux/generic/hack-4.14/902-debloat_proc.patch
@@ -393,7 +393,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
--- a/net/ipv4/route.c
+++ b/net/ipv4/route.c
-@@ -426,6 +426,9 @@ static struct pernet_operations ip_rt_pr
+@@ -427,6 +427,9 @@ static struct pernet_operations ip_rt_pr
static int __init ip_rt_proc_init(void)
{
diff --git a/target/linux/generic/pending-4.14/460-mtd-cfi_cmdset_0002-no-erase_suspend.patch b/target/linux/generic/pending-4.14/460-mtd-cfi_cmdset_0002-no-erase_suspend.patch
index 41f9d31cb0..3d39d3731d 100644
--- a/target/linux/generic/pending-4.14/460-mtd-cfi_cmdset_0002-no-erase_suspend.patch
+++ b/target/linux/generic/pending-4.14/460-mtd-cfi_cmdset_0002-no-erase_suspend.patch
@@ -14,7 +14,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
--- a/drivers/mtd/chips/cfi_cmdset_0002.c
+++ b/drivers/mtd/chips/cfi_cmdset_0002.c
-@@ -811,7 +811,7 @@ static int get_chip(struct map_info *map
+@@ -810,7 +810,7 @@ static int get_chip(struct map_info *map
return 0;
case FL_ERASING:
diff --git a/target/linux/generic/pending-4.14/461-mtd-cfi_cmdset_0002-add-buffer-write-cmd-timeout.patch b/target/linux/generic/pending-4.14/461-mtd-cfi_cmdset_0002-add-buffer-write-cmd-timeout.patch
index 932f219cf2..1b07791eca 100644
--- a/target/linux/generic/pending-4.14/461-mtd-cfi_cmdset_0002-add-buffer-write-cmd-timeout.patch
+++ b/target/linux/generic/pending-4.14/461-mtd-cfi_cmdset_0002-add-buffer-write-cmd-timeout.patch
@@ -7,7 +7,7 @@ Signed-off-by: George Kashperko <george@znau.edu.ua>
1 file changed, 1 insertion(+)
--- a/drivers/mtd/chips/cfi_cmdset_0002.c
+++ b/drivers/mtd/chips/cfi_cmdset_0002.c
-@@ -1839,6 +1839,7 @@ static int __xipram do_write_buffer(stru
+@@ -1838,6 +1838,7 @@ static int __xipram do_write_buffer(stru
/* Write Buffer Load */
map_write(map, CMD(0x25), cmd_adr);
diff --git a/target/linux/generic/pending-4.14/655-increase_skb_pad.patch b/target/linux/generic/pending-4.14/655-increase_skb_pad.patch
index fa47fe62a8..bccce61083 100644
--- a/target/linux/generic/pending-4.14/655-increase_skb_pad.patch
+++ b/target/linux/generic/pending-4.14/655-increase_skb_pad.patch
@@ -9,7 +9,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
--- a/include/linux/skbuff.h
+++ b/include/linux/skbuff.h
-@@ -2496,7 +2496,7 @@ static inline int pskb_network_may_pull(
+@@ -2508,7 +2508,7 @@ static inline int pskb_network_may_pull(
* NET_IP_ALIGN(2) + ethernet_header(14) + IP_header(20/40) + ports(8)
*/
#ifndef NET_SKB_PAD
diff --git a/target/linux/generic/pending-4.14/834-ledtrig-libata.patch b/target/linux/generic/pending-4.14/834-ledtrig-libata.patch
index 42e84c9a0a..e3fd88f6b0 100644
--- a/target/linux/generic/pending-4.14/834-ledtrig-libata.patch
+++ b/target/linux/generic/pending-4.14/834-ledtrig-libata.patch
@@ -65,7 +65,7 @@ Signed-off-by: Daniel Golle <daniel@makrotopia.org>
/**
* ata_build_rw_tf - Build ATA taskfile for given read/write request
* @tf: Target ATA taskfile
-@@ -5122,6 +5135,9 @@ struct ata_queued_cmd *ata_qc_new_init(s
+@@ -5125,6 +5138,9 @@ struct ata_queued_cmd *ata_qc_new_init(s
if (tag < 0)
return NULL;
}
@@ -75,7 +75,7 @@ Signed-off-by: Daniel Golle <daniel@makrotopia.org>
qc = __ata_qc_from_tag(ap, tag);
qc->tag = tag;
-@@ -6023,6 +6039,9 @@ struct ata_port *ata_port_alloc(struct a
+@@ -6028,6 +6044,9 @@ struct ata_port *ata_port_alloc(struct a
ap->stats.unhandled_irq = 1;
ap->stats.idle_irq = 1;
#endif
@@ -85,7 +85,7 @@ Signed-off-by: Daniel Golle <daniel@makrotopia.org>
ata_sff_port_init(ap);
return ap;
-@@ -6044,6 +6063,12 @@ static void ata_host_release(struct devi
+@@ -6049,6 +6068,12 @@ static void ata_host_release(struct devi
kfree(ap->pmp_link);
kfree(ap->slave_link);
@@ -98,7 +98,7 @@ Signed-off-by: Daniel Golle <daniel@makrotopia.org>
kfree(ap);
host->ports[i] = NULL;
}
-@@ -6490,7 +6515,23 @@ int ata_host_register(struct ata_host *h
+@@ -6495,7 +6520,23 @@ int ata_host_register(struct ata_host *h
host->ports[i]->print_id = atomic_inc_return(&ata_print_id);
host->ports[i]->local_port_no = i + 1;
}
@@ -134,7 +134,7 @@ Signed-off-by: Daniel Golle <daniel@makrotopia.org>
/*
* Define if arch has non-standard setup. This is a _PCI_ standard
-@@ -894,6 +897,12 @@ struct ata_port {
+@@ -895,6 +898,12 @@ struct ata_port {
#ifdef CONFIG_ATA_ACPI
struct ata_acpi_gtm __acpi_init_gtm; /* use ata_acpi_init_gtm() */
#endif
diff --git a/target/linux/layerscape/patches-4.14/202-core-linux-support-layerscape.patch b/target/linux/layerscape/patches-4.14/202-core-linux-support-layerscape.patch
index e421e556cd..2dd5b17603 100644
--- a/target/linux/layerscape/patches-4.14/202-core-linux-support-layerscape.patch
+++ b/target/linux/layerscape/patches-4.14/202-core-linux-support-layerscape.patch
@@ -580,7 +580,7 @@ Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
void __kfree_skb(struct sk_buff *skb);
extern struct kmem_cache *skbuff_head_cache;
-@@ -3315,6 +3316,7 @@ static inline void skb_free_datagram_loc
+@@ -3328,6 +3329,7 @@ static inline void skb_free_datagram_loc
}
int skb_kill_datagram(struct sock *sk, struct sk_buff *skb, unsigned int flags);
int skb_copy_bits(const struct sk_buff *skb, int offset, void *to, int len);
diff --git a/target/linux/layerscape/patches-4.14/819-sdhc-support-layerscape.patch b/target/linux/layerscape/patches-4.14/819-sdhc-support-layerscape.patch
index 02688c74cd..cc2d72290f 100644
--- a/target/linux/layerscape/patches-4.14/819-sdhc-support-layerscape.patch
+++ b/target/linux/layerscape/patches-4.14/819-sdhc-support-layerscape.patch
@@ -22,7 +22,7 @@ Signed-off-by: Yinbo Zhu <yinbo.zhu@nxp.com>
--- a/drivers/mmc/core/mmc.c
+++ b/drivers/mmc/core/mmc.c
-@@ -1174,6 +1174,9 @@ static int mmc_select_hs400(struct mmc_c
+@@ -1173,6 +1173,9 @@ static int mmc_select_hs400(struct mmc_c
goto out_err;
/* Switch card to DDR */
diff --git a/target/linux/mediatek/patches-4.14/0052-net-phy-add-FC.patch b/target/linux/mediatek/patches-4.14/0052-net-phy-add-FC.patch
index 46427a1d03..a2ce9dcd84 100644
--- a/target/linux/mediatek/patches-4.14/0052-net-phy-add-FC.patch
+++ b/target/linux/mediatek/patches-4.14/0052-net-phy-add-FC.patch
@@ -10,7 +10,7 @@ Signed-off-by: John Crispin <john@phrozen.org>
--- a/drivers/net/phy/phy_device.c
+++ b/drivers/net/phy/phy_device.c
-@@ -1948,7 +1948,7 @@ static struct phy_driver genphy_driver =
+@@ -1949,7 +1949,7 @@ static struct phy_driver genphy_driver =
.config_init = genphy_config_init,
.features = PHY_GBIT_FEATURES | SUPPORTED_MII |
SUPPORTED_AUI | SUPPORTED_FIBRE |
diff --git a/target/linux/oxnas/patches-4.14/999-libata-hacks.patch b/target/linux/oxnas/patches-4.14/999-libata-hacks.patch
index 0fb79dfaa8..d5c425b877 100644
--- a/target/linux/oxnas/patches-4.14/999-libata-hacks.patch
+++ b/target/linux/oxnas/patches-4.14/999-libata-hacks.patch
@@ -15,7 +15,7 @@
/* initialize internal qc */
/* XXX: Tag 0 is used for drivers with legacy EH as some
-@@ -5129,6 +5137,9 @@ struct ata_queued_cmd *ata_qc_new_init(s
+@@ -5132,6 +5140,9 @@ struct ata_queued_cmd *ata_qc_new_init(s
if (unlikely(ap->pflags & ATA_PFLAG_FROZEN))
return NULL;
@@ -25,7 +25,7 @@
/* libsas case */
if (ap->flags & ATA_FLAG_SAS_HOST) {
tag = ata_sas_allocate_tag(ap);
-@@ -5174,6 +5185,8 @@ void ata_qc_free(struct ata_queued_cmd *
+@@ -5177,6 +5188,8 @@ void ata_qc_free(struct ata_queued_cmd *
qc->tag = ATA_TAG_POISON;
if (ap->flags & ATA_FLAG_SAS_HOST)
ata_sas_free_tag(tag, ap);
@@ -36,8 +36,8 @@
--- a/include/linux/libata.h
+++ b/include/linux/libata.h
-@@ -923,6 +923,8 @@ struct ata_port_operations {
- void (*qc_prep)(struct ata_queued_cmd *qc);
+@@ -924,6 +924,8 @@ struct ata_port_operations {
+ enum ata_completion_errors (*qc_prep)(struct ata_queued_cmd *qc);
unsigned int (*qc_issue)(struct ata_queued_cmd *qc);
bool (*qc_fill_rtf)(struct ata_queued_cmd *qc);
+ int (*qc_new)(struct ata_port *ap);
@@ -45,7 +45,7 @@
/*
* Configuration and exception handling
-@@ -1013,6 +1015,9 @@ struct ata_port_operations {
+@@ -1014,6 +1016,9 @@ struct ata_port_operations {
void (*phy_reset)(struct ata_port *ap);
void (*eng_timeout)(struct ata_port *ap);
diff --git a/target/linux/ramips/patches-4.14/0037-mtd-cfi-cmdset-0002-force-word-write.patch b/target/linux/ramips/patches-4.14/0037-mtd-cfi-cmdset-0002-force-word-write.patch
index 39717bbad4..4f44aed3ab 100644
--- a/target/linux/ramips/patches-4.14/0037-mtd-cfi-cmdset-0002-force-word-write.patch
+++ b/target/linux/ramips/patches-4.14/0037-mtd-cfi-cmdset-0002-force-word-write.patch
@@ -44,7 +44,7 @@ Subject: [PATCH 37/53] mtd: cfi cmdset 0002 force word write
/* Atmel chips don't use the same PRI format as AMD chips */
static void fixup_convert_atmel_pri(struct mtd_info *mtd)
-@@ -1798,6 +1802,7 @@ static int cfi_amdstd_write_words(struct
+@@ -1797,6 +1801,7 @@ static int cfi_amdstd_write_words(struct
/*
* FIXME: interleaved mode not tested, and probably not supported!
*/
@@ -52,7 +52,7 @@ Subject: [PATCH 37/53] mtd: cfi cmdset 0002 force word write
static int __xipram do_write_buffer(struct map_info *map, struct flchip *chip,
unsigned long adr, const u_char *buf,
int len)
-@@ -1930,7 +1935,6 @@ static int __xipram do_write_buffer(stru
+@@ -1929,7 +1934,6 @@ static int __xipram do_write_buffer(stru
return ret;
}
@@ -60,7 +60,7 @@ Subject: [PATCH 37/53] mtd: cfi cmdset 0002 force word write
static int cfi_amdstd_write_buffers(struct mtd_info *mtd, loff_t to, size_t len,
size_t *retlen, const u_char *buf)
{
-@@ -2005,6 +2009,7 @@ static int cfi_amdstd_write_buffers(stru
+@@ -2004,6 +2008,7 @@ static int cfi_amdstd_write_buffers(stru
return 0;
}