aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKoen Vandeputte <koen.vandeputte@ncentric.com>2020-10-19 13:00:32 +0200
committerKoen Vandeputte <koen.vandeputte@ncentric.com>2020-10-21 15:34:11 +0200
commit14903d9d8cb2da2d3c2b793bdad51561dc7bb930 (patch)
tree8ec5b98e59f02b0b76d3af311226063dc6df8c83
parent03a029745fa274bc715af3d27343b8fe74fde8dd (diff)
downloadupstream-14903d9d8cb2da2d3c2b793bdad51561dc7bb930.tar.gz
upstream-14903d9d8cb2da2d3c2b793bdad51561dc7bb930.tar.bz2
upstream-14903d9d8cb2da2d3c2b793bdad51561dc7bb930.zip
kernel: bump 4.14 to 4.14.202
Refreshed all patches. Compile-tested on: ar71xx, cns3xxx, imx6, x86_64 Runtime-tested on: ar71xx, cns3xxx, imx6, x86_64 Signed-off-by: Koen Vandeputte <koen.vandeputte@ncentric.com>
-rw-r--r--include/kernel-version.mk4
-rw-r--r--target/linux/generic/backport-4.14/030-USB-serial-option-fix-dwm-158-3g-modem-interface.patch2
2 files changed, 3 insertions, 3 deletions
diff --git a/include/kernel-version.mk b/include/kernel-version.mk
index 67dec3c20e..a58b17fbf4 100644
--- a/include/kernel-version.mk
+++ b/include/kernel-version.mk
@@ -6,9 +6,9 @@ ifdef CONFIG_TESTING_KERNEL
KERNEL_PATCHVER:=$(KERNEL_TESTING_PATCHVER)
endif
-LINUX_VERSION-4.14 = .201
+LINUX_VERSION-4.14 = .202
-LINUX_KERNEL_HASH-4.14.201 = e228dc406c433df4d78c8e877230cc3899c1088c295de8f0d948fc766ae1235b
+LINUX_KERNEL_HASH-4.14.202 = 95c717ab5b0bdd2333e829f0507385fbe3424ceee810727f3a8551a0c74be328
remove_uri_prefix=$(subst git://,,$(subst http://,,$(subst https://,,$(1))))
sanitize_uri=$(call qstrip,$(subst @,_,$(subst :,_,$(subst .,_,$(subst -,_,$(subst /,_,$(1)))))))
diff --git a/target/linux/generic/backport-4.14/030-USB-serial-option-fix-dwm-158-3g-modem-interface.patch b/target/linux/generic/backport-4.14/030-USB-serial-option-fix-dwm-158-3g-modem-interface.patch
index ab6a8f3374..ebd90a8ef2 100644
--- a/target/linux/generic/backport-4.14/030-USB-serial-option-fix-dwm-158-3g-modem-interface.patch
+++ b/target/linux/generic/backport-4.14/030-USB-serial-option-fix-dwm-158-3g-modem-interface.patch
@@ -30,7 +30,7 @@ Signed-off-by: Johan Hovold <johan@kernel.org>
--- a/drivers/usb/serial/option.c
+++ b/drivers/usb/serial/option.c
-@@ -1996,7 +1996,8 @@ static const struct usb_device_id option
+@@ -2001,7 +2001,8 @@ static const struct usb_device_id option
{ USB_DEVICE_INTERFACE_CLASS(0x2001, 0x7d01, 0xff) }, /* D-Link DWM-156 (variant) */
{ USB_DEVICE_INTERFACE_CLASS(0x2001, 0x7d02, 0xff) },
{ USB_DEVICE_INTERFACE_CLASS(0x2001, 0x7d03, 0xff) },