aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorPhilip Prindeville <philipp@redfish-solutions.com>2017-09-15 11:03:52 -0600
committerHauke Mehrtens <hauke@hauke-m.de>2017-09-17 00:08:00 +0200
commit344fde35e3331dd999b38298b4743dce9a88583d (patch)
tree4e1a4402dd98f60575a085b19ab0ac77294fbe6f
parent010cddc2b00644abec8dcc700e2840216668e909 (diff)
downloadupstream-344fde35e3331dd999b38298b4743dce9a88583d.tar.gz
upstream-344fde35e3331dd999b38298b4743dce9a88583d.tar.bz2
upstream-344fde35e3331dd999b38298b4743dce9a88583d.zip
kernel: add packaging for Xeon iTCO watchdog timer
Signed-off-by: Philip Prindeville <philipp@redfish-solutions.com>
-rw-r--r--package/kernel/linux/modules/other.mk17
-rw-r--r--target/linux/x86/64/config-default2
2 files changed, 18 insertions, 1 deletions
diff --git a/package/kernel/linux/modules/other.mk b/package/kernel/linux/modules/other.mk
index 1b31a861f0..e4b2064dc4 100644
--- a/package/kernel/linux/modules/other.mk
+++ b/package/kernel/linux/modules/other.mk
@@ -1044,3 +1044,20 @@ define KernelPackage/w83627hf-wdt/description
endef
$(eval $(call KernelPackage,w83627hf-wdt))
+
+
+define KernelPackage/itco-wdt
+ SUBMENU:=$(OTHER_MENU)
+ TITLE:=Intel iTCO Watchdog Timer
+ KCONFIG:=CONFIG_ITCO_WDT \
+ CONFIG_ITCO_VENDOR_SUPPORT=y
+ FILES:=$(LINUX_DIR)/drivers/$(WATCHDOG_DIR)/iTCO_wdt.ko \
+ $(LINUX_DIR)/drivers/$(WATCHDOG_DIR)/iTCO_vendor_support.ko
+ AUTOLOAD:=$(call AutoLoad,50,iTCO_vendor_support iTCO_wdt,1)
+endef
+
+define KernelPackage/itco-wdt/description
+ Kernel module for Intel iTCO Watchdog Timer
+endef
+
+$(eval $(call KernelPackage,itco-wdt))
diff --git a/target/linux/x86/64/config-default b/target/linux/x86/64/config-default
index 1a3f9150c2..70838df407 100644
--- a/target/linux/x86/64/config-default
+++ b/target/linux/x86/64/config-default
@@ -201,7 +201,7 @@ CONFIG_INTEL_IDLE=y
# CONFIG_IOMMU_DEBUG is not set
# CONFIG_ISCSI_IBFT_FIND is not set
# CONFIG_ITCO_VENDOR_SUPPORT is not set
-CONFIG_ITCO_WDT=y
+# CONFIG_ITCO_WDT is not set
CONFIG_KALLSYMS_ABSOLUTE_PERCPU=y
# CONFIG_KVM_DEBUG_FS is not set
CONFIG_KVM_GUEST=y