aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAdrian Schmutzler <freifunk@adrianschmutzler.de>2020-07-29 21:59:18 +0200
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2020-08-10 00:05:20 +0200
commit2788db3d384ee2de6687ba8ab3bf790b8f7d132e (patch)
tree539a84d913bb37817e99d8a4aecdca0336b44e0b
parentd40ce8b32d146b9c7abecaa76fc69c3aa3e252d6 (diff)
downloadupstream-2788db3d384ee2de6687ba8ab3bf790b8f7d132e.tar.gz
upstream-2788db3d384ee2de6687ba8ab3bf790b8f7d132e.tar.bz2
upstream-2788db3d384ee2de6687ba8ab3bf790b8f7d132e.zip
hostapd: reorganize config selection hierarchy for WPA3
The current selection of DRIVER_MAKEOPTS and TARGET_LDFLAGS is exceptionally hard to read. This tries to make things a little easier by inverting the hierarchy of the conditions, so SSL_VARIANT is checked first and LOCAL_VARIANT is checked second. This exploits the fact that some of the previous conditions were unnecessary, e.g. there is no hostapd-mesh*, so we don't need to exclude this combination. It also should make it a little easier to see which options are actually switched by SSL_VARIANT and which by LOCAL_VARIANT. The patch is supposed to be cosmetic. However, the improvement for readers and the maintained consistency with master qualify this for backporting. Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de> (cherry picked from commit c4dd7fc23bfcf3b3f1a838668bb070edc9db5d4b)
-rw-r--r--package/network/services/hostapd/Makefile34
1 files changed, 18 insertions, 16 deletions
diff --git a/package/network/services/hostapd/Makefile b/package/network/services/hostapd/Makefile
index bb02449836..8e32b97a04 100644
--- a/package/network/services/hostapd/Makefile
+++ b/package/network/services/hostapd/Makefile
@@ -90,29 +90,31 @@ ifneq ($(LOCAL_VARIANT),mini)
DRIVER_MAKEOPTS += CONFIG_IEEE80211W=$(CONFIG_DRIVER_11W_SUPPORT)
endif
-ifeq ($(LOCAL_VARIANT),full)
- ifeq ($(SSL_VARIANT),openssl)
- DRIVER_MAKEOPTS += CONFIG_TLS=openssl CONFIG_SAE=y CONFIG_OWE=y CONFIG_SUITEB192=y CONFIG_AP=y CONFIG_MESH=y
- TARGET_LDFLAGS += -lcrypto -lssl
+ifeq ($(SSL_VARIANT),openssl)
+ DRIVER_MAKEOPTS += CONFIG_TLS=openssl CONFIG_SAE=y
+ TARGET_LDFLAGS += -lcrypto -lssl
+
+ ifeq ($(LOCAL_VARIANT),mesh)
+ DRIVER_MAKEOPTS += CONFIG_AP=y CONFIG_MESH=y
endif
- ifeq ($(SSL_VARIANT),wolfssl)
- DRIVER_MAKEOPTS += CONFIG_TLS=wolfssl CONFIG_WPS_NFC=1 CONFIG_SAE=y CONFIG_OWE=y CONFIG_SUITEB192=y CONFIG_AP=y CONFIG_MESH=y
- TARGET_LDFLAGS += -lwolfssl
+ ifeq ($(LOCAL_VARIANT),full)
+ DRIVER_MAKEOPTS += CONFIG_OWE=y CONFIG_SUITEB192=y CONFIG_AP=y CONFIG_MESH=y
endif
endif
-ifneq ($(LOCAL_TYPE),hostapd)
+ifeq ($(SSL_VARIANT),wolfssl)
+ DRIVER_MAKEOPTS += CONFIG_TLS=wolfssl CONFIG_SAE=y
+ TARGET_LDFLAGS += -lwolfssl
+
ifeq ($(LOCAL_VARIANT),mesh)
- ifeq ($(SSL_VARIANT),openssl)
- DRIVER_MAKEOPTS += CONFIG_TLS=openssl CONFIG_AP=y CONFIG_SAE=y CONFIG_MESH=y
- TARGET_LDFLAGS += -lcrypto -lssl
- endif
- ifeq ($(SSL_VARIANT),wolfssl)
- DRIVER_MAKEOPTS += CONFIG_TLS=wolfssl CONFIG_WPS_NFC=1 CONFIG_AP=y CONFIG_SAE=y CONFIG_MESH=y
- TARGET_LDFLAGS += -lwolfssl
- endif
+ DRIVER_MAKEOPTS += CONFIG_AP=y CONFIG_MESH=y CONFIG_WPS_NFC=1
endif
+ ifeq ($(LOCAL_VARIANT),full)
+ DRIVER_MAKEOPTS += CONFIG_OWE=y CONFIG_SUITEB192=y CONFIG_AP=y CONFIG_MESH=y CONFIG_WPS_NFC=1
+ endif
+endif
+ifneq ($(LOCAL_TYPE),hostapd)
ifdef CONFIG_WPA_RFKILL_SUPPORT
DRIVER_MAKEOPTS += NEED_RFKILL=y
endif